summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLaurento Frittella (mrfree) <laurento.frittella@gmail.com>2010-07-29 14:51:23 +0000
committerLaurento Frittella (mrfree) <laurento.frittella@gmail.com>2010-07-29 14:51:23 +0000
commit6b90ccaa5281d7d5bbec6462d032f75219ab4fe9 (patch)
tree6fd8de69fe1380ff1d875d2ec1ee221004828b7c /dev-python/ncrypt
parentapp-crypt/codegroup: New Ebuild for bug 285381 (diff)
downloadsunrise-reviewed-6b90ccaa5281d7d5bbec6462d032f75219ab4fe9.tar.gz
sunrise-reviewed-6b90ccaa5281d7d5bbec6462d032f75219ab4fe9.tar.bz2
sunrise-reviewed-6b90ccaa5281d7d5bbec6462d032f75219ab4fe9.zip
dev-python/ncrypt: New Ebuild for bug 139679 thanks to Tommy[D]
svn path=/sunrise/; revision=11055
Diffstat (limited to 'dev-python/ncrypt')
-rw-r--r--dev-python/ncrypt/ChangeLog8
-rw-r--r--dev-python/ncrypt/Manifest5
-rw-r--r--dev-python/ncrypt/files/cinit.patch120
-rw-r--r--dev-python/ncrypt/metadata.xml6
-rw-r--r--dev-python/ncrypt/ncrypt-0.6.4.ebuild29
5 files changed, 168 insertions, 0 deletions
diff --git a/dev-python/ncrypt/ChangeLog b/dev-python/ncrypt/ChangeLog
new file mode 100644
index 000000000..86ef98b39
--- /dev/null
+++ b/dev-python/ncrypt/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-python/ncrypt
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 29 Jul 2010; Laurento Frittella (mrfree) <laurento.frittella@gmail.com>
+ +ncrypt-0.6.4.ebuild, +files/cinit.patch, +metadata.xml:
+ New Ebuild for bug 139679 thanks to Tommy[D]
+
diff --git a/dev-python/ncrypt/Manifest b/dev-python/ncrypt/Manifest
new file mode 100644
index 000000000..ebf457916
--- /dev/null
+++ b/dev-python/ncrypt/Manifest
@@ -0,0 +1,5 @@
+AUX cinit.patch 4031 RMD160 ce7e4f49163a8d689ab93307cd564118a23e6922 SHA1 1a7f092b5d8abccdd421ae9115d217e95a25f550 SHA256 ae09d30249d3a5f2bbcb378bbf7e61ef870df6c8a6a3f33e25768b798e71bb58
+DIST ncrypt-0.6.4.tar.gz 30348 RMD160 d3a4576d048c4a608e8c9069186cd3f22dced3a0 SHA1 6156175e34ff09a3b3df7b14247b7279c7bb082c SHA256 fe50e60598aeb72ff47692e8a3025197cc93b33d430bca230991e58dfcb36a1d
+EBUILD ncrypt-0.6.4.ebuild 547 RMD160 b708661dbfc06da33581787e7933c9557b8e8e1e SHA1 f706e7e7317a0c0b22decf3bda651e32326692b3 SHA256 52715dd559a3fbd1395227ba06cfde324391f8b50c48c8b636b3369b61a1e865
+MISC ChangeLog 299 RMD160 1b77985ab262e4ce75c029cfc3c66ade7a2dafb4 SHA1 471a81148bf2aeea4d54761e14e590e0bc9c8c18 SHA256 3a987e732a99d63875057a49bbe705f86fddb1b34fd7685b015d654974200d5f
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/dev-python/ncrypt/files/cinit.patch b/dev-python/ncrypt/files/cinit.patch
new file mode 100644
index 000000000..7ddc1fdbf
--- /dev/null
+++ b/dev-python/ncrypt/files/cinit.patch
@@ -0,0 +1,120 @@
+diff -Naur ncrypt-0.6.4.orig/ncrypt_bignum.pyx ncrypt-0.6.4/ncrypt_bignum.pyx
+--- ncrypt-0.6.4.orig/ncrypt_bignum.pyx 2006-10-09 09:36:51.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_bignum.pyx 2010-07-29 16:10:06.000632053 +0200
+@@ -29,7 +29,7 @@
+ cdef class BigNum :
+ cdef BIGNUM *bn
+
+- def __new__( self, x=None ) :
++ def __cinit__( self, x=None ) :
+ self.bn = BN_new()
+
+ cdef _free( self ) :
+diff -Naur ncrypt-0.6.4.orig/ncrypt_cipher.pyx ncrypt-0.6.4/ncrypt_cipher.pyx
+--- ncrypt-0.6.4.orig/ncrypt_cipher.pyx 2006-10-09 09:36:51.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_cipher.pyx 2010-07-29 16:09:08.733881668 +0200
+@@ -43,7 +43,7 @@
+ cdef EVP_CIPHER *c
+ cdef object cipherAlgo, cipherMode
+
+- def __new__( self, cipherAlgo, cipherMode ) :
++ def __cinit__( self, cipherAlgo, cipherMode ) :
+ self.c = NULL
+
+ def __dealloc__( self ) :
+@@ -84,7 +84,7 @@
+ cdef EVP_CIPHER_CTX *ctx
+ cdef int cipherFinalized
+
+- def __new__( self, cipherType, key, iv, encryptFlag ) :
++ def __cinit__( self, cipherType, key, iv, encryptFlag ) :
+ self.outBuffer = NULL
+ self.outBufferSize = 0
+ self.ctx = AllocCipherContext()
+diff -Naur ncrypt-0.6.4.orig/ncrypt_dh.pyx ncrypt-0.6.4/ncrypt_dh.pyx
+--- ncrypt-0.6.4.orig/ncrypt_dh.pyx 2006-10-09 09:36:51.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_dh.pyx 2010-07-29 16:09:34.944631842 +0200
+@@ -50,7 +50,7 @@
+ class DHError( ncrypt_err.BaseLibraryError ) : pass
+
+ cdef class DH :
+- def __new__( self ) :
++ def __cinit__( self ) :
+ self.dh = DH_new()
+
+ def __dealloc__( self ) :
+diff -Naur ncrypt-0.6.4.orig/ncrypt_digest.pyx ncrypt-0.6.4/ncrypt_digest.pyx
+--- ncrypt-0.6.4.orig/ncrypt_digest.pyx 2006-10-09 09:36:51.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_digest.pyx 2010-07-29 16:08:22.175632123 +0200
+@@ -32,7 +32,7 @@
+ ALGORITHMS = ('MD5','SHA1','SHA224','SHA256','SHA384','SHA512')
+
+ cdef class DigestType :
+- def __new__( self, evpMd ) :
++ def __cinit__( self, evpMd ) :
+ self.m = NULL
+
+ def __dealloc__( self ) :
+@@ -60,7 +60,7 @@
+ cdef int digestFinalized
+ cdef readonly object digestType
+
+- def __new__( self, digestType ) :
++ def __cinit__( self, digestType ) :
+ self.ctx = NULL
+ self.digestFinalized = 0
+
+diff -Naur ncrypt-0.6.4.orig/ncrypt_rsa.pyx ncrypt-0.6.4/ncrypt_rsa.pyx
+--- ncrypt-0.6.4.orig/ncrypt_rsa.pyx 2006-10-09 09:36:52.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_rsa.pyx 2010-07-29 16:09:23.573880691 +0200
+@@ -117,7 +117,7 @@
+ PADDING_PKCS1_OAEP = 1
+
+ cdef class RSAKey :
+- def __new__( self ) :
++ def __cinit__( self ) :
+ self.rsa = RSA_new()
+
+ def __dealloc__( self ) :
+diff -Naur ncrypt-0.6.4.orig/ncrypt_ssl.pyx ncrypt-0.6.4/ncrypt_ssl.pyx
+--- ncrypt-0.6.4.orig/ncrypt_ssl.pyx 2006-10-09 09:36:52.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_ssl.pyx 2010-07-29 16:09:54.873632053 +0200
+@@ -172,7 +172,7 @@
+ cdef class SSLContext :
+ cdef SSL_CTX *c
+
+- def __new__( self, sslMethod, sslMethodType=-1 ) :
++ def __cinit__( self, sslMethod, sslMethodType=-1 ) :
+ self.c = NULL
+
+ def __dealloc__( self ) :
+@@ -245,7 +245,7 @@
+ cdef object sslContext
+ cdef readonly object sock
+
+- def __new__( self, sslContext, sock ) :
++ def __cinit__( self, sslContext, sock ) :
+ self.s = NULL
+
+ def __dealloc__( self ) :
+diff -Naur ncrypt-0.6.4.orig/ncrypt_x509.pyx ncrypt-0.6.4/ncrypt_x509.pyx
+--- ncrypt-0.6.4.orig/ncrypt_x509.pyx 2006-10-09 09:36:52.000000000 +0200
++++ ncrypt-0.6.4/ncrypt_x509.pyx 2010-07-29 16:08:47.989640504 +0200
+@@ -128,7 +128,7 @@
+ cdef class X509Name :
+ cdef X509_NAME *xn
+
+- def __new__( self ) :
++ def __cinit__( self ) :
+ self.xn = NULL
+
+ def __dealloc__( self ) :
+@@ -203,7 +203,7 @@
+ raise X509Error, 'unable to find field name: %s' % fieldName
+
+ cdef class X509Certificate :
+- def __new__( self, data=None ) :
++ def __cinit__( self, data=None ) :
+ self.x = NULL
+
+ def __dealloc__( self ) :
diff --git a/dev-python/ncrypt/metadata.xml b/dev-python/ncrypt/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/dev-python/ncrypt/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/dev-python/ncrypt/ncrypt-0.6.4.ebuild b/dev-python/ncrypt/ncrypt-0.6.4.ebuild
new file mode 100644
index 000000000..1ab4203c7
--- /dev/null
+++ b/dev-python/ncrypt/ncrypt-0.6.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils python
+
+DESCRIPTION="A python wrapper for OpenSSL"
+HOMEPAGE="http://tachyon.in/ncrypt/"
+SRC_URI="http://fs.tachyon.in.s3.amazonaws.com/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ dev-python/pyrex"
+RDEPEND="${DEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ epatch "${FILESDIR}/cinit.patch"
+}