summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Grant (dgrant) <davidgrant@gmail.com>2007-03-11 11:58:59 +0000
committerDavid Grant (dgrant) <davidgrant@gmail.com>2007-03-11 11:58:59 +0000
commit8d3f75406731ef6372e921b4b1cd902978cdae46 (patch)
tree02a0f662c292423ba952f5afa81f0bb95af77aeb /dev-python
parentdev-python/path: new ebuild for Bug #170209 (diff)
downloadsunrise-reviewed-8d3f75406731ef6372e921b4b1cd902978cdae46.tar.gz
sunrise-reviewed-8d3f75406731ef6372e921b4b1cd902978cdae46.tar.bz2
sunrise-reviewed-8d3f75406731ef6372e921b4b1cd902978cdae46.zip
dev-python/path: added python_mod_optimize and python_mod_cleanup calls
svn path=/sunrise/; revision=3201
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/path/ChangeLog3
-rw-r--r--dev-python/path/Manifest4
-rw-r--r--dev-python/path/path-2.1.ebuild10
3 files changed, 15 insertions, 2 deletions
diff --git a/dev-python/path/ChangeLog b/dev-python/path/ChangeLog
index fe8f1da82..80553c895 100644
--- a/dev-python/path/ChangeLog
+++ b/dev-python/path/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 11 Mar 2007; David Grant (dgrant) <davidgrant@gmail.com> path-2.1.ebuild:
+ added python_mod_optimize and python_mod_cleanup calls
+
11 Mar 2007; David Grant (dgrant) <davidgrant@gmail.com> +path-2.1.ebuild,
+metadata.xml:
new ebuild for Bug #170209
diff --git a/dev-python/path/Manifest b/dev-python/path/Manifest
index 5a9f6c137..46786c83f 100644
--- a/dev-python/path/Manifest
+++ b/dev-python/path/Manifest
@@ -1,4 +1,4 @@
DIST path-2.1.zip 14204 RMD160 2051a0d5d6940d78beb06ff8fb8942824cb1ab4e SHA1 f5fdb1bacb47a9b68e135fda43d10f8a392ceb0d SHA256 b4032d166deac1f819a9485259031f29e6906411beb980c2d8f840b2e93afada
-EBUILD path-2.1.ebuild 512 RMD160 a86e23ddcb7ec746f9f39837c83a83d3fbc7aa63 SHA1 8626be60f018e9ded234224bbe9117bc5c87e191 SHA256 d93efbfb080acd4664eecf01ad5c8ee0ecf38ed4f499e939f5926118602c79fe
-MISC ChangeLog 240 RMD160 e078e1f9e695db3faf31295425dc5053b757445f SHA1 8cbd391898e8d026f7ad14045ca5c6f86d1bb4d7 SHA256 a9b6556c7ebd694b5138a44596823393bee3a9526539017544ee475ebd19f2a8
+EBUILD path-2.1.ebuild 731 RMD160 42cf75e2164025d2a8bded1760368cf14db31600 SHA1 aa8b8dada286fe35dbbaf33ca18a98b9a6ea0eb2 SHA256 da3d9bd606949c46306f20c648c9ea97c8b5c1806f85f17debc733b0f2397da2
+MISC ChangeLog 374 RMD160 30f5fe5a3dbcebdbe64f9714379c2bb02867a3e0 SHA1 e9442b23fbfa6ec8843eb2d7d6b2485be0640d02 SHA256 424689440425b23f45dd0bf5987680e86d1812a90e411ad8bd5c398c448f71b1
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/path/path-2.1.ebuild b/dev-python/path/path-2.1.ebuild
index 67991c7d9..914050195 100644
--- a/dev-python/path/path-2.1.ebuild
+++ b/dev-python/path/path-2.1.ebuild
@@ -21,3 +21,13 @@ src_install() {
insinto /usr/$(get_libdir)/python${PYVER}/site-packages/
doins path.py
}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup ${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages
+}