summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Cendron <scen@gentoo.org>2007-06-13 21:31:24 +0000
committerDavide Cendron <scen@gentoo.org>2007-06-13 21:31:24 +0000
commit9aad59201907155d87574f3b167b82d4fa33eb9a (patch)
tree641cb71f3817469bf66e954bf041b403fce22863 /games-fps/chocolate-doom
parentMasking SVN live ebuild of games-fps/chocolate-doom (diff)
downloadsunrise-reviewed-9aad59201907155d87574f3b167b82d4fa33eb9a.tar.gz
sunrise-reviewed-9aad59201907155d87574f3b167b82d4fa33eb9a.tar.bz2
sunrise-reviewed-9aad59201907155d87574f3b167b82d4fa33eb9a.zip
games-fps/chocolate-doom: New Ebuild for bug 147329
svn path=/sunrise/; revision=3911
Diffstat (limited to 'games-fps/chocolate-doom')
-rw-r--r--games-fps/chocolate-doom/ChangeLog8
-rw-r--r--games-fps/chocolate-doom/Manifest3
-rw-r--r--games-fps/chocolate-doom/chocolate-doom-9999.ebuild76
-rw-r--r--games-fps/chocolate-doom/metadata.xml10
4 files changed, 97 insertions, 0 deletions
diff --git a/games-fps/chocolate-doom/ChangeLog b/games-fps/chocolate-doom/ChangeLog
new file mode 100644
index 000000000..11c928f1b
--- /dev/null
+++ b/games-fps/chocolate-doom/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-fps/chocolate-doom
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 13 Jun 2007; Davide Cendron (scen) <scen@gentoo.org>
+ +chocolate-doom-9999.ebuild, +metadata.xml:
+ New Ebuild for bug 147329
+
diff --git a/games-fps/chocolate-doom/Manifest b/games-fps/chocolate-doom/Manifest
new file mode 100644
index 000000000..662e3d96f
--- /dev/null
+++ b/games-fps/chocolate-doom/Manifest
@@ -0,0 +1,3 @@
+EBUILD chocolate-doom-9999.ebuild 1906 RMD160 ece856b84cd39e2de3493802a3f6c9b9021351fa SHA1 b1469846753c94d073812db9c6547d64430af6be SHA256 34ddc078d5853d05250dab3f6a9405585d6bc4bb29d84f079c52c4ffae403ee0
+MISC ChangeLog 255 RMD160 30089a8e4b190d0bb26ea1fa35f1bfd09d6433e5 SHA1 860ccd18635d9c08484780f7bd5fa4c06909fbbc SHA256 68d8fcb9b272410c5611166f87b08ae732d19ff4e6385a822a8f0d12a36c08d9
+MISC metadata.xml 326 RMD160 3b636449b105b44cec0dc6d89bc8add0fdb737b5 SHA1 b584675e63e8849a17255747158cd08550ded578 SHA256 80046d6f1b00409ae5aad2128675641b997e52571b775c45fee47e45bff7a799
diff --git a/games-fps/chocolate-doom/chocolate-doom-9999.ebuild b/games-fps/chocolate-doom/chocolate-doom-9999.ebuild
new file mode 100644
index 000000000..0b0a99d86
--- /dev/null
+++ b/games-fps/chocolate-doom/chocolate-doom-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools subversion games
+
+DESCRIPTION="Doom port designed to act identically to the original game"
+HOMEPAGE="http://www.chocolate-doom.org/"
+ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/chocolate-doom/trunk/chocolate-doom"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="server"
+
+DEPEND=">=media-libs/libsdl-1.1.3
+ media-libs/sdl-mixer
+ media-libs/sdl-net"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+
+ # Change default search path for IWAD
+ sed -i \
+ -e "s:/usr/share/games/doom:${GAMES_DATADIR}/doom-data:" \
+ src/d_iwad.c || die "sed main.c failed"
+
+ sed -i \
+ -e "s:^gamesdir =.*:gamesdir = ${GAMES_BINDIR}:" \
+ setup/Makefile.am || die "sed Makefile.am failed"
+}
+
+src_compile() {
+
+ eautoreconf
+
+ egamesconf \
+ --disable-sdltest \
+ --disable-dependency-tracking \
+ || die "egamesconf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dogamesbin ${PN} failed"
+ dogamesbin setup/chocolate-setup || die "dogamesbin chocolate-setup failed"
+ if use server ; then
+ dogamesbin src/chocolate-server || die "dogamesbin chocolate-server failed"
+ fi
+
+ doicon data/${PN}.png || die "doicon failed"
+ make_desktop_entry ${PN} "Chocolate Doom"
+ doicon data/chocolate-setup.png || die "doicon failed"
+ make_desktop_entry chocolate-setup "Chocolate Doom Setup" chocolate-setup.png
+
+ doman man/${PN}.6 || die "doman failed"
+ dodoc AUTHORS BUGS ChangeLog HACKING NEWS README TODO || die "dodoc failed"
+
+ dodir "${GAMES_DATADIR}/doom-data" || die "dodir failed"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ echo
+ elog "To play the original Doom levels, place doom.wad and/or doom2.wad"
+ elog "into ${GAMES_DATADIR}/doom-data, then run: ${PN}"
+ elog
+ elog "To configure game options run: chocolate-setup"
+ echo
+}
diff --git a/games-fps/chocolate-doom/metadata.xml b/games-fps/chocolate-doom/metadata.xml
new file mode 100644
index 000000000..db93454a1
--- /dev/null
+++ b/games-fps/chocolate-doom/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd></herd>
+ <longdescription lang="en">
+ Chocolate Doom is a Doom source port which aims to reproduce the behavior of
+ 'Vanilla' Doom as closely as possible.
+</longdescription>
+</pkgmetadata>
+