summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyRXP/pyRXP-9999.ebuild')
-rw-r--r--dev-python/pyRXP/pyRXP-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyRXP/pyRXP-9999.ebuild b/dev-python/pyRXP/pyRXP-9999.ebuild
new file mode 100644
index 000000000..1472228ae
--- /dev/null
+++ b/dev-python/pyRXP/pyRXP-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils subversion
+
+DESCRIPTION="Binding to RXP, a very fast validating XML parser."
+HOMEPAGE="http://www.reportlab.org/pyrxp.html"
+ESVN_REPO_URI="http://svn.reportlab.com/svn/public/${PN}/trunk/src"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc examples"
+
+DOCS="README"
+
+src_install()
+{
+ if use doc;then
+ DOCS="${DOCS} docs/*"
+ fi
+
+ distutils_src_install
+
+ if use examples;then
+ docinto examples
+ dodoc examples/* || die "dodoc examples code failed"
+ fi
+}