summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/gq/gq-1.2.2.ebuild')
-rw-r--r--net-nds/gq/gq-1.2.2.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/net-nds/gq/gq-1.2.2.ebuild b/net-nds/gq/gq-1.2.2.ebuild
index 316fbf317..f962e7ecb 100644
--- a/net-nds/gq/gq-1.2.2.ebuild
+++ b/net-nds/gq/gq-1.2.2.ebuild
@@ -2,8 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
-
DESCRIPTION="A GTK+-based LDAP client"
HOMEPAGE="http://www.gq-project.org/"
SRC_URI="mirror://sourceforge/gqclient/${P}.tar.gz"
@@ -11,34 +9,35 @@ SRC_URI="mirror://sourceforge/gqclient/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="kerberos ssl sasl"
+
+# Feel free to make conditional once it is not automagic
+# http://www.gentoo.org/proj/en/qa/automagic.xml
+IUSE="kerberos" # sasl ssl
RDEPEND=">=x11-libs/gtk+-2
>=net-nds/openldap-2
kerberos? ( app-crypt/mit-krb5 )
- ssl? ( dev-libs/openssl )
+ dev-libs/openssl
dev-libs/libxml2
>=dev-libs/glib-2
x11-libs/pango
- sasl? ( dev-libs/cyrus-sasl )"
+ dev-libs/cyrus-sasl
+ >=gnome-base/gnome-keyring-0.4.4"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=gnome-base/gnome-keyring-0.4.4"
+ dev-util/pkgconfig"
src_compile() {
local myconf="--enable-browser-dnd --enable-cache --disable-update-mimedb"
-
use kerberos && myconf="${myconf} --with-kerberos-prefix=/usr"
econf ${myconf} || die "econf failed"
-
emake || die "emake failed"
}
src_install() {
rm -f ${D}/usr/share/locale/locale.alias
emake DESTDIR="${D}" install || die "emake failed"
- dodoc AUTHORS ChangeLog COPYING NEWS README* TODO
+ dodoc AUTHORS ChangeLog NEWS README* TODO
}