summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2010-01-19 09:00:18 +0000
committerJohan Bergström (jbergstroem) <bugs@bergstroem.nu>2010-01-19 09:00:18 +0000
commite034709d5eac35cae28cbce60e2e4d7c60572b32 (patch)
tree82d6804521aaeff53e78e701fd8b1cfc85cdb5ad /dev-python
parentdev-python/eventlet: Version bump. Add support for ABI (diff)
downloadsunrise-e034709d5eac35cae28cbce60e2e4d7c60572b32.tar.gz
sunrise-e034709d5eac35cae28cbce60e2e4d7c60572b32.tar.bz2
sunrise-e034709d5eac35cae28cbce60e2e4d7c60572b32.zip
dev-python/pottymouth: Version bump, minor rewrite of test function
svn path=/sunrise/; revision=9902
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pottymouth/ChangeLog6
-rw-r--r--dev-python/pottymouth/Manifest6
-rw-r--r--dev-python/pottymouth/pottymouth-1.2.1.ebuild (renamed from dev-python/pottymouth/pottymouth-1.2.0.ebuild)11
3 files changed, 15 insertions, 8 deletions
diff --git a/dev-python/pottymouth/ChangeLog b/dev-python/pottymouth/ChangeLog
index a4d002e0c..7740045d8 100644
--- a/dev-python/pottymouth/ChangeLog
+++ b/dev-python/pottymouth/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-python/pottymouth
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Jan 2010; Johan Bergström (jbergstroem) <bugs@bergstroem.nu>
+ -pottymouth-1.2.0.ebuild, +pottymouth-1.2.1.ebuild:
+ Version bump, minor rewrite of test function
+
01 Dec 2009; Johan Bergström (jbergstroem) <bugs@bergstroem.nu>
-pottymouth-1.1.5.ebuild, +pottymouth-1.2.0.ebuild:
Version bump
diff --git a/dev-python/pottymouth/Manifest b/dev-python/pottymouth/Manifest
index a3b726472..177a27ec1 100644
--- a/dev-python/pottymouth/Manifest
+++ b/dev-python/pottymouth/Manifest
@@ -1,4 +1,4 @@
-DIST PottyMouth-1.2.0.tar.gz 26879 RMD160 2d82314e81b5f4b612cadee88f96e0767945bf20 SHA1 fe20fb0d3628b8860ed2bc8322abbba2de20b0a0 SHA256 5ac61e3b930b54e8d244650f2cfea91229713bfe04374f1a761a4e7accc2a703
-EBUILD pottymouth-1.2.0.ebuild 592 RMD160 70a6e81947ec1d9aed36bd6f02aa22729c3dbc83 SHA1 5d0c2472992053288d85dfb0e5966e2f1f370e04 SHA256 758a26c68e6b2644dab9c0d429ff4a2a64731a090985fb2e41aaa98380c7b1b6
-MISC ChangeLog 1076 RMD160 44b4cbb87a211506ea60d7af3efd33d039fad198 SHA1 b58bd14f52961490152272dd2e77d347d89b76f5 SHA256 4b3f37137f7ad11ceb34b3c2e43f1aefd74602baa5b2e99099f974dcafb28ad0
+DIST PottyMouth-1.2.1.tar.gz 26983 RMD160 02e5209a77d8a01c1836d7aad78643c12150c56b SHA1 4d970b613ec2b9575762a03610a7cb70d51cfbd5 SHA256 80e1df73fef0053fa3e028050f822ef1a62e1f0a25c9fc7d8745d88921dba32c
+EBUILD pottymouth-1.2.1.ebuild 668 RMD160 0d92d8233263efa965ba550f26679e13d669b5fc SHA1 c998090bbb3df3776b6722f587885a0e5e62af53 SHA256 31671e46ceeb9b27722870d37eb56c17fbf9c05b534f57aa35c8f16db854a446
+MISC ChangeLog 1245 RMD160 9380cf2e52446c8a2a57ddd40a8fa1300952fa40 SHA1 0a09ac849438a9180f7de60fe4fc506eddb4f237 SHA256 9401111d2cc5d0475b03ec5627d603f486f28e40e550360a683be08a4c2fb837
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-python/pottymouth/pottymouth-1.2.0.ebuild b/dev-python/pottymouth/pottymouth-1.2.1.ebuild
index b76bbcffe..80d4dbdca 100644
--- a/dev-python/pottymouth/pottymouth-1.2.0.ebuild
+++ b/dev-python/pottymouth/pottymouth-1.2.1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-NEED_PYTHON=2.4
-SUPPORT_PYTHON_ABIS=1
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
@@ -24,5 +23,9 @@ RESTRICT_PYTHON_ABIS="3*"
S=${WORKDIR}/${MY_P}
src_test() {
- ${python} test.py || die "Tests failed"
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test.py || die "Tests failed"
+ }
+ python_execute_function testing
+
}