summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2010-10-13 02:08:15 +0000
committerNathan Phillip Brink (binki) <ohnobinki@ohnopublishing.net>2010-10-13 02:08:15 +0000
commitacebaa0336f219a0a694f2ecab47e15cff54eb7a (patch)
treecf8e8cb2d87c129ea502526915fefeb92434ac64 /dev-ruby
parentdev-ruby/grit: Replace all_ruby_prepare() with RUBY_PATCHES. (diff)
downloadsunrise-acebaa0336f219a0a694f2ecab47e15cff54eb7a.tar.gz
sunrise-acebaa0336f219a0a694f2ecab47e15cff54eb7a.tar.bz2
sunrise-acebaa0336f219a0a694f2ecab47e15cff54eb7a.zip
dev-ruby/ruby-mpd: Use ruby-ng eclass. Fix HOMEPAGE.
(Portage version: 2.2_rc88-r1/svn/Linux x86_64) svn path=/sunrise/; revision=11421
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-mpd/ChangeLog6
-rw-r--r--dev-ruby/ruby-mpd/ruby-mpd-0.2.3.ebuild14
2 files changed, 16 insertions, 4 deletions
diff --git a/dev-ruby/ruby-mpd/ChangeLog b/dev-ruby/ruby-mpd/ChangeLog
index 2078ece61..27561c4f8 100644
--- a/dev-ruby/ruby-mpd/ChangeLog
+++ b/dev-ruby/ruby-mpd/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-ruby/ruby-mpd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 13 Oct 2010; Nathan Phillip Brink (ohnobinki)
+ <ohnobinki@ohnopublishing.net> ruby-mpd-0.2.3.ebuild:
+ Use ruby-ng eclass. Fix HOMEPAGE.
+
29 Jun 2008; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
ruby-mpd-0.2.3.ebuild:
Add IUSE+SLOT
diff --git a/dev-ruby/ruby-mpd/ruby-mpd-0.2.3.ebuild b/dev-ruby/ruby-mpd/ruby-mpd-0.2.3.ebuild
index 583a07e76..55f99193e 100644
--- a/dev-ruby/ruby-mpd/ruby-mpd-0.2.3.ebuild
+++ b/dev-ruby/ruby-mpd/ruby-mpd-0.2.3.ebuild
@@ -2,12 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit ruby
+EAPI=2
-MY_P=${P/ruby-mpd/mpd-rb}
+USE_RUBY="ruby18"
+
+inherit ruby-ng
+
+MY_P=mpd-rb-${PV}
DESCRIPTION="Ruby class for communicating with an MPD server"
-HOMEPAGE="http://www.andsoforth.com/geek/mpd_rb.html"
+HOMEPAGE="http://rubyforge.org/projects/mpd"
SRC_URI="http://rubyforge.org/frs/download.php/8040/${MY_P}.tar.gz"
LICENSE="GPL-2"
@@ -18,3 +22,7 @@ IUSE=""
RDEPEND="media-sound/mpd"
S=${WORKDIR}/${MY_P}
+
+each_ruby_install() {
+ doruby lib/mpd.rb
+}