summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-04-13 21:57:09 +0000
committerMichał Górny <mgorny@gentoo.org>2010-04-13 21:57:09 +0000
commit191b44f8f46c3302d4ce3bb859d933d7ad04233c (patch)
treec2a3a0ffcb5bed426f24fc9a6e960f0b9144b214 /gnome-extra
parentdev-ruby/dnsruby: version bump, fixed doc and test USE flags (diff)
downloadsunrise-191b44f8f46c3302d4ce3bb859d933d7ad04233c.tar.gz
sunrise-191b44f8f46c3302d4ce3bb859d933d7ad04233c.tar.bz2
sunrise-191b44f8f46c3302d4ce3bb859d933d7ad04233c.zip
gnome-extra/gnome-globalmenu: New ebuild for bug #205203. Thanks to Serhij S. Stasyuk and other ebuild contributors.
svn path=/sunrise/; revision=10449
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-globalmenu/ChangeLog9
-rw-r--r--gnome-extra/gnome-globalmenu/Manifest5
-rw-r--r--gnome-extra/gnome-globalmenu/files/50gnome-globalmenu2
-rw-r--r--gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild74
-rw-r--r--gnome-extra/gnome-globalmenu/metadata.xml8
5 files changed, 98 insertions, 0 deletions
diff --git a/gnome-extra/gnome-globalmenu/ChangeLog b/gnome-extra/gnome-globalmenu/ChangeLog
new file mode 100644
index 000000000..67e633bb8
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for gnome-extra/gnome-globalmenu
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 13 Apr 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
+ +files/50gnome-globalmenu, +gnome-globalmenu-0.7.9.ebuild, +metadata.xml:
+ New ebuild for bug #205203. Thanks to Serhij S. Stasyuk and other ebuild
+ contributors.
+
diff --git a/gnome-extra/gnome-globalmenu/Manifest b/gnome-extra/gnome-globalmenu/Manifest
new file mode 100644
index 000000000..634874fe5
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/Manifest
@@ -0,0 +1,5 @@
+AUX 50gnome-globalmenu 58 RMD160 1c0bd8562a63d603d118c787b85b56bc8d9a459a SHA1 ba43e55d624aaf512f5301284c4bb07af04f15ca SHA256 65edc18c2ea847abbe9f51cb2a53f8f87569fc5aec37cdc3113f1d053e13605e
+DIST gnome-globalmenu-0.7.9.tar.bz2 598736 RMD160 a1b05817aa164bb94d2f9835b9d90b39086d1a0a SHA1 7a51f2927f0d59c29e131464586734ad29f87903 SHA256 a5ac112169c175ab2ee6f4ba02655f9af3b7f1a9294056506ad92abb05b1159c
+EBUILD gnome-globalmenu-0.7.9.ebuild 1997 RMD160 450915d029c9b00f6a7ba6500d3d1b116382e05d SHA1 5d8205ce60d520691bfe4b3e47df4c46600f2218 SHA256 dfa8aad6be90147f1256d4cde54a25a0beef4440147b5d7f6ae85ecd5aa42363
+MISC ChangeLog 361 RMD160 2a1547d3171fab8869005207a930370f5091c711 SHA1 09ab841764775be5fd1f704222c50d6964f6a176 SHA256 4a328c0c22c863f40c377f1f946242ae52548638148c47a9c5d8d7e1313113b9
+MISC metadata.xml 242 RMD160 f88dd8483ceb013ce5845ade103514fd560af99c SHA1 7b1ed0a37ce7e85de6cb95b03ba2b0bdcd7b8aa8 SHA256 118963a28d2fce880003ad3fb5d86343866ba4669ef68027d43068c0d8898910
diff --git a/gnome-extra/gnome-globalmenu/files/50gnome-globalmenu b/gnome-extra/gnome-globalmenu/files/50gnome-globalmenu
new file mode 100644
index 000000000..f3016d3ec
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/files/50gnome-globalmenu
@@ -0,0 +1,2 @@
+COLON_SEPARATED=GTK_MODULES
+GTK_MODULES=globalmenu-plugin
diff --git a/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild b/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild
new file mode 100644
index 000000000..55e335755
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/gnome-globalmenu-0.7.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+inherit gnome2
+
+DESCRIPTION="Global menubar applet for GNOME/XFCE"
+HOMEPAGE="http://code.google.com/p/gnome2-globalmenu/"
+SRC_URI="http://gnome2-globalmenu.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gnome xfce"
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/gconf:2
+ gnome-base/gnome-menus
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libwnck
+ gnome? (
+ gnome-base/gnome-panel
+ x11-libs/libnotify )
+ xfce? ( xfce-base/xfce4-panel )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+RESTRICT=test
+
+pkg_setup() {
+ # gir is not in gx86, and it doesn't affect typical use
+ # the tests are broken (they do not compile)
+ G2CONF="${G2CONF}
+ --docdir=/usr/share/doc/${PF}
+ --without-gir
+ --disable-tests
+ $(use_with gnome gnome-panel)
+ $(use_with xfce xfce4-panel)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # If 'gnome' is the only used flag, then we assume we're facing a happy
+ # GNOME user and we print only the instructions on how to enable the GTK+
+ # module from within GNOME Applet. Otherwise, we install an env.d file
+ # enabling the module by default.
+ if use xfce || ! use gnome; then
+ doenvd "${FILESDIR}"/50gnome-globalmenu || die
+ fi
+}
+
+pkg_postinst() {
+ if use xfce || ! use gnome; then
+ elog "The globalmenu GTK+ module will be enabled through the following file:"
+ elog " /etc/env.d/50gnome-globalmenu"
+
+ if use xfce; then
+ elog
+ elog "Please notice that due to an upstream bug, xfce4 plugin does not hide"
+ elog "the application menu bar by default. The suggested workaround is"
+ elog "to run the following command when session is started:"
+ elog " globalmenu-settings show-local-menu FALSE"
+ elog "( http://code.google.com/p/gnome2-globalmenu/issues/detail?id=555 )"
+ fi
+ elif use gnome; then
+ elog "You can enable the globalmenu GTK+ through the Applet preferences"
+ elog "window."
+ fi
+}
diff --git a/gnome-extra/gnome-globalmenu/metadata.xml b/gnome-extra/gnome-globalmenu/metadata.xml
new file mode 100644
index 000000000..a58ff8e92
--- /dev/null
+++ b/gnome-extra/gnome-globalmenu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>maintainer-wanted</herd>
+ <use>
+ <flag name='xfce'>Build the Xfce panel applet.</flag>
+ </use>
+</pkgmetadata>