summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Van Swearingen (Zythran) <jovie1024@yahoo.com>2009-10-11 22:04:05 +0000
committerJoseph Van Swearingen (Zythran) <jovie1024@yahoo.com>2009-10-11 22:04:05 +0000
commit22085a094bdaf53ee4ebe2778aa29dda5c5bf2af (patch)
treef3b75e4733bda78a145f36094558bec93ca353d8 /media-video
parentapp-admin/procinfo-ng: version bump (diff)
downloadsunrise-22085a094bdaf53ee4ebe2778aa29dda5c5bf2af.tar.gz
sunrise-22085a094bdaf53ee4ebe2778aa29dda5c5bf2af.tar.bz2
sunrise-22085a094bdaf53ee4ebe2778aa29dda5c5bf2af.zip
media-video/huludesktop: New Ebuild for bug 288372. Thanks chiiph and jlec.
svn path=/sunrise/; revision=9345
Diffstat (limited to 'media-video')
-rw-r--r--media-video/huludesktop/ChangeLog8
-rw-r--r--media-video/huludesktop/Manifest5
-rw-r--r--media-video/huludesktop/huludesktop-0.9.3.ebuild44
-rw-r--r--media-video/huludesktop/metadata.xml5
4 files changed, 62 insertions, 0 deletions
diff --git a/media-video/huludesktop/ChangeLog b/media-video/huludesktop/ChangeLog
new file mode 100644
index 000000000..7c7b8ca4e
--- /dev/null
+++ b/media-video/huludesktop/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-video/huludesktop
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 11 Oct 2009; Joseph Van Swearingen (Zythran) <jovie1024@yahoo.com>
+ +huludesktop-0.9.3.ebuild, +metadata.xml:
+ New Ebuild for bug 288372. Thanks chiiph and jlec.
+
diff --git a/media-video/huludesktop/Manifest b/media-video/huludesktop/Manifest
new file mode 100644
index 000000000..481eba9a4
--- /dev/null
+++ b/media-video/huludesktop/Manifest
@@ -0,0 +1,5 @@
+DIST huludesktop-0.9.3.i386.rpm 628327 RMD160 ed4c5aef6e5837b02261a1f13c381ca93cc1c6cd SHA1 60bf9194833c8806be9b56de5b9c005cdf78a20c SHA256 b8afc16c2708ef1ee053a3e6bbd1b37dbb8e113785eea27655fae95f46d28da1
+DIST huludesktop-0.9.3.x86_64.rpm 695716 RMD160 c685c59355c69f442e0aada5ab59c46977c9f7be SHA1 ced3498384ca4e3060fe24c8f2d83b6b40a2c867 SHA256 0e49011cfc43385555101d3e1507543a674b2869c6c2c28d2226407c441c5cff
+EBUILD huludesktop-0.9.3.ebuild 1301 RMD160 9ce28e4b4990b17bd1980a1f182b1de213645246 SHA1 c43ffb889b06c405c69dd8c2086248b1862b9a99 SHA256 ff359ad06efcf4535b135c11e0776623e4dc01c1f3e4a5fc5f441588994f0527
+MISC ChangeLog 292 RMD160 9a9164dc54e95f75f32022daffb01133eb07ae3e SHA1 ef9cb7e8e4c6c684bc1dc4f68445a8dcd56d4096 SHA256 af4dde5a7ee85ef0a7ddb07a9ebbdb64dc78d175613bc302dda7b4ed844b6cd7
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/media-video/huludesktop/huludesktop-0.9.3.ebuild b/media-video/huludesktop/huludesktop-0.9.3.ebuild
new file mode 100644
index 000000000..511d470db
--- /dev/null
+++ b/media-video/huludesktop/huludesktop-0.9.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils multilib rpm
+
+DESCRIPTION="Hulu desktop"
+HOMEPAGE="http://www.hulu.com/labs/hulu-desktop-linux"
+SRC_URI="amd64? ( http://download.hulu.com/${PN}.x86_64.rpm -> ${P}.x86_64.rpm )
+ x86? ( http://download.hulu.com/${PN}.i386.rpm -> ${P}.i386.rpm )"
+
+LICENSE="Hulu-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="www-plugins/adobe-flash
+ x11-libs/gtk+:2
+ dev-libs/glib"
+
+src_install() {
+ insinto /etc/${PN}
+ doins etc/${PN}/hd_keymap.ini || die "Failed doins"
+
+ dobin usr/bin/${PN} || die "Failed dobin"
+
+ domenu usr/share/applications/${PN}.desktop || die "Failed domenu"
+ doicon usr/share/pixmaps/${PN}.png || die "Failed doicon"
+ dodoc usr/share/doc/${PN}/README || die "Failed dodoc"
+}
+
+pkg_postinst() {
+ einfo "This program can utilize a remote control. Please install"
+ einfo "app-misc/lirc if you wish to use a remote with ${PN}."
+ einfo
+ ewarn "The file ~/.${PN} should be created for you if you start Hulu Desktop"
+ ewarn "but the path to the flash plugin is not set by default."
+ ewarn
+ ewarn "You need to add the following to ~/.${PN}:"
+ ewarn "[flash]"
+ ewarn "flash_location = /usr/$(get_libdir)/nsbrowser/plugins/libflashplayer.so"
+}
diff --git a/media-video/huludesktop/metadata.xml b/media-video/huludesktop/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/media-video/huludesktop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>