summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2006-06-19 15:43:36 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2006-06-19 15:43:36 +0000
commit88fc606c42382c7f2373513732b1db5cbd7b3d10 (patch)
tree9c0f4eccba41c86d94bb4cb18426289f9bd982ca /scripts
parentqc-usb-messenger-1.3.ebuild, initial ebuild for bug #75705 (diff)
downloadsunrise-88fc606c42382c7f2373513732b1db5cbd7b3d10.tar.gz
sunrise-88fc606c42382c7f2373513732b1db5cbd7b3d10.tar.bz2
sunrise-88fc606c42382c7f2373513732b1db5cbd7b3d10.zip
script/ovl-ebuild.sh: list ebuilds isntalled not from portage dir
svn path=/sunrise/; revision=137
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/ovl-ebuilds.sh26
1 files changed, 26 insertions, 0 deletions
diff --git a/scripts/ovl-ebuilds.sh b/scripts/ovl-ebuilds.sh
new file mode 100755
index 000000000..5cd905166
--- /dev/null
+++ b/scripts/ovl-ebuilds.sh
@@ -0,0 +1,26 @@
+#!/bin/bash
+#
+# Copyright 2006 Piotr Jaroszyński <peper@aster.pl>
+# Distributed under the terms of the GNU General Public License v2
+
+source /etc/make.conf
+OVERLAY=""
+
+echo "This will take a while depending on no. of installed packages."
+echo "Packages installed not from portage dir:"
+echo
+while read EBUILD_PATH; do
+ OVERLAY=${EBUILD_PATH%/*/*/*}
+ CATEGORY=$(basename ${EBUILD_PATH%/*/*})
+ PKG=$(basename ${EBUILD_PATH})
+
+ if [[ ${OVERLAY} != ${LASTOVERLAY} ]]; then
+ echo "${OVERLAY}:"
+ LASTOVERLAY=${OVERLAY}
+ fi
+
+ echo -e "\t${CATEGORY}/${PKG}"
+done < <(bzcat /var/db/pkg/*/*/environment.bz2 | grep EBUILD=/ | grep -v $PORTDIR | sort \
+| sed -e 's/EBUILD=//' -e 's/.ebuild//')
+
+unset OVERLAY LASTOVERLAY CATEGORY PKG