summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xenman/xenman-0.4.2.2.ebuild')
-rw-r--r--app-emulation/xenman/xenman-0.4.2.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/xenman/xenman-0.4.2.2.ebuild b/app-emulation/xenman/xenman-0.4.2.2.ebuild
new file mode 100644
index 000000000..62a41832f
--- /dev/null
+++ b/app-emulation/xenman/xenman-0.4.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+KEYWORDS="~x86"
+
+DESCRIPTION="An intuitive, GUI based Xen management tool covering all phases of the operational lifecycle."
+HOMEPAGE="http://sourceforge.net/projects/xenman/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-emulation/xen-3.0.2
+ >=app-emulation/xen-tools-3.0.2
+ >=app-arch/rpm-4.4.6
+ >=dev-python/pygtk-2.8.6
+ >=x11-libs/vte-0.12.2
+ dev-lang/python"
+
+pkg_setup() {
+ if ! built_with_use app-arch/rpm python; then
+ eerror "app-arch/rpm has to be built with python support."
+ die "Missing python USE-flag for app-arch/rpm"
+ fi
+ if ! built_with_use x11-libs/vte python; then
+ eerror "x11-libs/vte has to be built with python support."
+ die "Missing python USE-flag for x11-libs/vte"
+ fi
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r pixmaps/ xenman.glade
+
+ newsbin xenman.py xenman
+
+ dodoc changelog.txt README xenman.conf-*
+}