summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/scratchbox-devkit-perl/scratchbox-devkit-perl-1.0.4.ebuild')
-rw-r--r--sys-devel/scratchbox-devkit-perl/scratchbox-devkit-perl-1.0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-devel/scratchbox-devkit-perl/scratchbox-devkit-perl-1.0.4.ebuild b/sys-devel/scratchbox-devkit-perl/scratchbox-devkit-perl-1.0.4.ebuild
new file mode 100644
index 000000000..7b69cea80
--- /dev/null
+++ b/sys-devel/scratchbox-devkit-perl/scratchbox-devkit-perl-1.0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MAJOR_VERSION=${PV%\.[0-9]}
+
+SBOX_GROUP="sbox"
+RESTRICT="strip"
+
+DESCRIPTION="Scratchbox is a cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/${P}-i386.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="=sys-devel/scratchbox-${MAJOR_VERSION}*"
+RDEPEND="${DEPEND}"
+
+TARGET_DIR="/opt/scratchbox"
+
+S=${WORKDIR}/scratchbox
+
+src_install() {
+ dodir ${TARGET_DIR}
+ cp -pRP * "${D}/${TARGET_DIR}"
+}