summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild')
-rw-r--r--x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild b/x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild
new file mode 100644
index 0000000..4a445db
--- /dev/null
+++ b/x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="NVIDIA Tegra2 X.org driver"
+
+HOMEPAGE="http://developer.nvidia.com/content/linux-tegra-release-12-alpha-1-released"
+SRC_URI="http://developer.download.nvidia.com/assets/mobile/files/tegra-linux-12.alpha.1.0.tar.gz"
+
+
+LICENSE="nvidia"
+SLOT="0"
+KEYWORDS="arm"
+
+IUSE=""
+DEPEND="=x11-base/xorg-server-1.10*
+ =sys-libs/tegra-libs-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="strip mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd ldk/nv_tegra
+ unpack ./tegra-drivers-abi10.tbz2
+}
+
+src_install() {
+ cd ldk/nv_tegra
+ insinto /
+ doins -r usr
+}