summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/gcc/gcc-4.1.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.1.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-4.1.0-r1.ebuild b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
new file mode 100644
index 0000000..83ab6d0
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.8"
+UCLIBC_VER="1.1"
+
+inherit toolchain
+
+KEYWORDS=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=${CATEGORY}/binutils-2.15.94"
+
+src_prepare() {
+ toolchain_src_prepare
+
+ use vanilla && return 0
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}