summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/reelbox-ehd-tools/reelbox-ehd-tools-13986.ebuild')
-rw-r--r--media-video/reelbox-ehd-tools/reelbox-ehd-tools-13986.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-video/reelbox-ehd-tools/reelbox-ehd-tools-13986.ebuild b/media-video/reelbox-ehd-tools/reelbox-ehd-tools-13986.ebuild
new file mode 100644
index 0000000..d13b5cc
--- /dev/null
+++ b/media-video/reelbox-ehd-tools/reelbox-ehd-tools-13986.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+RESTRICT="strip mirror"
+
+DESCRIPTION="eHD PCI card: tools svn r${PV}"
+HOMEPAGE="http://www.reel-multimedia.com"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="=media-video/reelbox-ehd-headers-${PV}
+ media-libs/libpng"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/hdshm3
+
+src_prepare() {
+
+ sed -i "${WORKDIR}"/hdfbshot/Makefile \
+ -e "s:^include:#include:" \
+ -e "s:(CC):(CC) ${CFLAGS}:"
+
+ sed -i "${S}"/x86/hdtsplay/Makefile -e "s:LDFLAGS =:LDFLAGS ?=:"
+
+ sed -i Makefile \
+ -e "s:gcc-3.3:gcc:g" \
+ -e "s:g++-3.3:g++:g" \
+ -e "s:x86/driver::"
+
+ einfo "Changing framebuffer device to /dev/fb_reel"
+ find . -type f -exec sed -i "s:/dev/fb0:/dev/fb_reel:g" {} \;
+}
+
+src_compile() {
+
+ emake clean || die "emake clean failed"
+ emake x86 || die "emake x86 failed"
+ cd x86/hdtsplay
+ emake || die "emake hdtsplay failed"
+ cd "${WORKDIR}"/hdfbshot
+ emake || die "emake hdfbshot failed"
+}
+
+src_install() {
+
+ dobin "${S}"/x86/hdboot/hdboot
+ dobin "${S}"/x86/hdctrld/hdctrld
+ dobin "${S}"/x86/shmnetd/shmnetd
+ dobin "${WORKDIR}"/hdfbshot/hdfbshot
+ dobin "${S}"/x86/hdfbctl/hdfbctl
+ dobin "${S}"/x86/hdtsplay/hdtsplay
+}