summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-10-29 21:37:16 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-10-29 21:37:16 +0000
commit7a03cebda3fb3f5a882b9619aac4c2c4588bf071 (patch)
tree3596675ad088d601bd56cca7e7a44f13ef68337a /net-misc/asterisk-app_rtxfax
downloadvoip-7a03cebda3fb3f5a882b9619aac4c2c4588bf071.tar.gz
voip-7a03cebda3fb3f5a882b9619aac4c2c4588bf071.tar.bz2
voip-7a03cebda3fb3f5a882b9619aac4c2c4588bf071.zip
Initial import of private gentoo-voip repos
svn path=/trunk/; revision=2
Diffstat (limited to 'net-misc/asterisk-app_rtxfax')
-rw-r--r--net-misc/asterisk-app_rtxfax/Manifest3
-rw-r--r--net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre20.ebuild40
-rw-r--r--net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre20-gentoo.diff56
-rw-r--r--net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre201
4 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/asterisk-app_rtxfax/Manifest b/net-misc/asterisk-app_rtxfax/Manifest
new file mode 100644
index 0000000..6c63e45
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/Manifest
@@ -0,0 +1,3 @@
+MD5 f4454e015a4482c35a5011181978ed6a asterisk-app_rtxfax-0.0.2_pre20.ebuild 843
+MD5 f93631da6831298970c2bee289446fd2 files/digest-asterisk-app_rtxfax-0.0.2_pre20 82
+MD5 362967e8723a04bed027389ea1514603 files/app_rtxfax-0.0.2_pre20-gentoo.diff 1587
diff --git a/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre20.ebuild b/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre20.ebuild
new file mode 100644
index 0000000..5a85885
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre20.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-app_rtxfax/asterisk-app_rtxfax-0.0.2_pre18.ebuild,v 1.2 2005/07/08 20:53:05 dholm Exp $
+
+IUSE=""
+
+inherit eutils
+
+MY_PN="app_rtxfax"
+
+DESCRIPTION="Asterisk applications for sending and receiving faxes"
+HOMEPAGE="http://www.soft-switch.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=media-libs/spandsp-0.0.2_pre20
+ >=net-misc/asterisk-1.0.5-r1"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # use asterisk-config...
+ epatch ${FILESDIR}/${MY_PN}-0.0.2_pre20-gentoo.diff
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README
+}
diff --git a/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre20-gentoo.diff b/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre20-gentoo.diff
new file mode 100644
index 0000000..27f03a8
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/files/app_rtxfax-0.0.2_pre20-gentoo.diff
@@ -0,0 +1,56 @@
+--- /dev/null 1970-01-01 01:00:00.000000000 +0100
++++ Makefile 2005-09-05 23:59:22.000000000 +0200
+@@ -0,0 +1,27 @@
++.EXPORT_ALL_VARIABLES:
++
++CC=cc
++INSTALL=install
++AST_CFG=/usr/bin/asterisk-config
++
++AST_INCLUDE_DIR=/usr/include/asterisk
++AST_CONFIG_DIR=/etc/asterisk
++AST_MODULES_DIR=/usr/lib/asterisk/modules
++
++TARGETS:=app_rxfax.so app_txfax.so
++
++CFLAGS=$(shell $(AST_CFG) --cflags)
++SOLINK=$(shell $(AST_CFG) --solink)
++LIBS=-lspandsp -ltiff
++
++SUBDIR=$(shell [ -f $(AST_INCLUDE_DIR)/channel_pvt.h ] && echo "asterisk-1.0.x" || echo "asterisk-1.1.x")
++
++.PHONY: all install $(SUBDIR)
++
++all: $(SUBDIR)
++
++$(SUBDIR):
++ $(MAKE) -C $(SUBDIR) all
++
++install:
++ $(MAKE) -C $(SUBDIR) install
+--- /dev/null 1970-01-01 01:00:00.000000000 +0100
++++ asterisk-1.0.x/Makefile 2005-09-06 00:00:05.000000000 +0200
+@@ -0,0 +1,10 @@
++all: $(TARGETS)
++
++$(TARGETS): $(patsubst %.so,%.c,$(TARGETS))
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_rxfax.so app_rxfax.c $(LIBS)
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_txfax.so app_txfax.c $(LIBS)
++
++install:
++ for x in $(TARGETS); do \
++ $(INSTALL) -D -m 755 $$x $(DESTDIR)$(AST_MODULES_DIR)/$$x; \
++ done
+--- /dev/null 1970-01-01 01:00:00.000000000 +0100
++++ asterisk-1.1.x/Makefile 2005-09-06 00:00:37.000000000 +0200
+@@ -0,0 +1,10 @@
++all: $(TARGETS)
++
++$(TARGETS): $(patsubst %.so,%.c,$(TARGETS))
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_rxfax.so app_rxfax.c $(LIBS)
++ $(CC) $(CFLAGS) $(SOLINK) -fPIC -o app_txfax.so app_txfax.c $(LIBS)
++
++install:
++ for x in $(TARGETS); do \
++ $(INSTALL) -D -m 755 $$x $(DESTDIR)$(AST_MODULES_DIR)/$$x; \
++ done
diff --git a/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre20 b/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre20
new file mode 100644
index 0000000..a5b3cc1
--- /dev/null
+++ b/net-misc/asterisk-app_rtxfax/files/digest-asterisk-app_rtxfax-0.0.2_pre20
@@ -0,0 +1 @@
+MD5 fc15fb6a827b49771d748b9ae71ce539 asterisk-app_rtxfax-0.0.2_pre20.tar.bz2 7755