summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/vzctl/vzctl-3.0.14.ebuild')
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.14.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/sys-cluster/vzctl/vzctl-3.0.14.ebuild b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
index c05b8d0..2891832 100644
--- a/sys-cluster/vzctl/vzctl-3.0.14.ebuild
+++ b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.13.ebuild,v 1.2 2006/12/03 08:33:48 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.14.ebuild,v 1.1 2007/01/18 09:40:03 phreak Exp $
-inherit bash-completion eutils flag-o-matic multilib
+inherit eutils multilib
DESCRIPTION="OpenVZ VPS control utility"
HOMEPAGE="http://openvz.org/"
@@ -29,22 +29,16 @@ src_unpack() {
}
src_compile() {
- econf --libdir=/usr/$(get_libdir) || die "econf failed!"
+ econf --libdir=/usr/$(get_libdir) \
+ $(use_enable bash-completion bashcomp) \
+ $(use_enable logrotate ) \
+ $(use_enable udev ) || die "econf failed!"
+
emake CFLAGS="${CFLAGS}" || die "emake failed!"
}
src_install() {
make DESTDIR="${D}" install install-gentoo || die "make install failed"
-
- # Remove udev files unless USE=udev
- use udev || rm -rf "${D}"/etc/udev
-
- # Remove the bash-completion and use dobashcompletion to install it in the
- # right place!
- dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh.in vzctl
-
- # Remove the logrotate entry unless USE=logrotate
- use logrotate || rm -rf "${D}"/etc/logrotate.d
}
pkg_postinst() {