summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2013-08-07 16:59:40 +0200
committerDavid Heidelberger <david.heidelberger@ixit.cz>2013-08-07 16:59:40 +0200
commit690dcd78fb094c9584b3b83a7baac686127fe666 (patch)
tree2098d3bca5ff9e4ff0f9d4ae1694504425a0f605 /app-benchmarks
parentx11-base/xorg-drivers: add video_cards_radeonsi flag with dependency on glamo... (diff)
downloadx11-690dcd78fb094c9584b3b83a7baac686127fe666.tar.gz
x11-690dcd78fb094c9584b3b83a7baac686127fe666.tar.bz2
x11-690dcd78fb094c9584b3b83a7baac686127fe666.zip
app-benchmarks/glmark2: bump 2012.12_p278, lastest tarball
Package-Manager: portage-2.2.0_alpha194
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/glmark2/Manifest2
-rw-r--r--app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch11
-rw-r--r--app-benchmarks/glmark2/glmark2-2011.08.ebuild44
-rw-r--r--app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild90
-rw-r--r--app-benchmarks/glmark2/metadata.xml1
5 files changed, 103 insertions, 45 deletions
diff --git a/app-benchmarks/glmark2/Manifest b/app-benchmarks/glmark2/Manifest
index f51e3c1a..688954fd 100644
--- a/app-benchmarks/glmark2/Manifest
+++ b/app-benchmarks/glmark2/Manifest
@@ -1 +1 @@
-DIST glmark2-2011.08.tar.gz 2147647 SHA256 42351988a5c5ed31b78dec2423f1a48eb18028b6066d14d6bc903ae20f81f341
+DIST glmark2-2012.12_p278.tar.gz 7778563 SHA256 e77a5026c108c4272986f9f0ccdc1474292c19192705ec984ceed8db44dd3d2e SHA512 a998b23819538cc29363aa95f5ad8a9252fa90950e37796f59577fdde2c3374e98eb847d44fb2d75e7ec955f0f1146aec1f5ac91024dc03b74e7afa8ce266851 WHIRLPOOL 84db3c7b5c368edb4a8222f49c7d2fef79e30c9b65e038b835b566cc208d4a6bd1a068707a780f917c27884182841fd0739326083580566fffb4e560339d3183
diff --git a/app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch b/app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch
new file mode 100644
index 00000000..24532574
--- /dev/null
+++ b/app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch
@@ -0,0 +1,11 @@
+diff -Naur a/glmark2/trunk/src/image-reader.cpp b/glmark2/trunk/src/image-reader.cpp
+--- a/glmark2/trunk/src/image-reader.cpp 2013-08-07 16:21:26.655989291 +0200
++++ b/glmark2/trunk/src/image-reader.cpp 2013-08-07 16:20:29.053983661 +0200
+@@ -21,6 +21,7 @@
+ */
+ #include <png.h>
+ #include <jpeglib.h>
++#include <cstring>
+ #include <memory>
+
+ #include "image-reader.h"
diff --git a/app-benchmarks/glmark2/glmark2-2011.08.ebuild b/app-benchmarks/glmark2/glmark2-2011.08.ebuild
deleted file mode 100644
index 17c21134..00000000
--- a/app-benchmarks/glmark2/glmark2-2011.08.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit waf-utils
-
-DESCRIPTION="Opengl test suite"
-HOMEPAGE="https://launchpad.net/glmark2"
-SRC_URI="http://launchpad.net/${PN}/2011.11/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gles2"
-
-RDEPEND="media-libs/libpng
- media-libs/mesa[gles2?]
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- rm -rf "${S}/src/libpng"
- sed -i -e 's#libpng12#libpng#g' "${S}/wscript ${S}/src/wscript_build" || die
-}
-
-src_configure() {
- : ${WAF_BINARY:="${S}/waf"}
-
- local myconf
-
- if use gles2; then
- myconf += "--enable-glesv2"
- fi
-
- # it does not know --libdir specification, dandy huh
- CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
- --prefix=/usr \
- --enable-gl \
- ${myconf} \
- configure || die "configure failed"
-}
diff --git a/app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild b/app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild
new file mode 100644
index 00000000..e444e97c
--- /dev/null
+++ b/app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit waf-utils python-single-r1
+
+DESCRIPTION="Opengl test suite"
+HOMEPAGE="https://launchpad.net/glmark2"
+SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/278 -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~arm ~amd64 ~x86"
+IUSE="drm +gles2 opengl wayland X"
+
+RDEPEND="media-libs/libpng
+ media-libs/mesa[gles2?]
+ X? ( x11-libs/libX11 )
+ wayland? ( <dev-libs/wayland-1.2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( opengl gles2 )
+ || ( drm wayland X )"
+
+S="${WORKDIR}/~${PN}-dev/${PN}/trunk/"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-cstring_include.patch"
+ rm -rf "${S}/src/libpng"
+ sed -i "s/libpng15/libpng/g" "${S}/wscript" # allow build with >= libpng:1.6
+}
+
+src_configure() {
+ : ${WAF_BINARY:="${S}/waf"}
+
+ local myconf
+
+ if use X; then
+ if use opengl; then
+ myconf+="x11-gl"
+ fi
+ if use opengl && use gles2; then
+ myconf+=","
+ fi
+ if use gles2; then
+ myconf+="x11-glesv2"
+ fi
+
+ fi
+ if use drm; then
+ if use X; then
+ myconf+=","
+ fi
+ if use opengl; then
+ myconf+="drm-gl"
+ fi
+ if use opengl && use gles2; then
+ myconf+=","
+ fi
+ if use gles2; then
+ myconf+="drm-glesv2"
+ fi
+
+ fi
+ if use wayland; then
+ if use X || use drm; then
+ myconf+=","
+ fi
+ if use opengl; then
+ myconf+="wayland-gl"
+ fi
+ if use opengl && use gles2; then
+ myconf+=","
+ fi
+ if use gles2; then
+ myconf+="wayland-glesv2"
+ fi
+
+ fi
+
+ # it does not know --libdir specification, dandy huh
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ --prefix=/usr \
+ --with-flavors ${myconf} \
+ configure || die "configure failed"
+}
diff --git a/app-benchmarks/glmark2/metadata.xml b/app-benchmarks/glmark2/metadata.xml
index 344ceb1f..42c0a9a5 100644
--- a/app-benchmarks/glmark2/metadata.xml
+++ b/app-benchmarks/glmark2/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>x11</herd>
<use>
+ <flag name='drm'>Enable DRM backend support</flag>
<flag name='gles2'>Enable GLES2 support</flag>
</use>
</pkgmetadata>