summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-08-28 23:11:12 -0700
committerMatt Turner <mattst88@gmail.com>2012-08-28 23:11:12 -0700
commit6aed39f3484ec16c926a6ae0e266fa62f9c73d57 (patch)
tree344f2733a7cfe3e0ba33f6e49e257c4db7119869 /x11-apps
parentx11-apps/mesa-progs: Update to git-2 eclass (diff)
downloadx11-6aed39f3484ec16c926a6ae0e266fa62f9c73d57.tar.gz
x11-6aed39f3484ec16c926a6ae0e266fa62f9c73d57.tar.bz2
x11-6aed39f3484ec16c926a6ae0e266fa62f9c73d57.zip
x11-apps/mesa-progs: Oops. Add src_prepare()
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/mesa-progs/mesa-progs-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/x11-apps/mesa-progs/mesa-progs-9999.ebuild b/x11-apps/mesa-progs/mesa-progs-9999.ebuild
index 4aa42584..63efdbae 100644
--- a/x11-apps/mesa-progs/mesa-progs-9999.ebuild
+++ b/x11-apps/mesa-progs/mesa-progs-9999.ebuild
@@ -10,11 +10,11 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/${MY_PN/-//}"
EGIT_PROJECT="mesa-progs"
if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-2"
- EXPERIMENTAL="true"
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
fi
-inherit toolchain-funcs ${GIT_ECLASS}
+inherit base autotools toolchain-funcs ${GIT_ECLASS}
DESCRIPTION="Mesa's OpenGL utility and demo programs (glxgears and glxinfo)"
HOMEPAGE="http://mesa3d.sourceforge.net/"
@@ -39,6 +39,12 @@ src_unpack() {
[[ $PV = 9999* ]] && git-2_src_unpack
}
+src_prepare() {
+ base_src_prepare
+
+ eautoreconf
+}
+
src_configure() {
# We're not using the complete buildsystem if we only want to build
# glxinfo and glxgears.