summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xen-4.17-efi.patch')
-rw-r--r--xen-4.17-efi.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/xen-4.17-efi.patch b/xen-4.17-efi.patch
new file mode 100644
index 0000000..d3c102d
--- /dev/null
+++ b/xen-4.17-efi.patch
@@ -0,0 +1,13 @@
+diff --git a/xen/arch/x86/arch.mk b/xen/arch/x86/arch.mk
+index 227d439a..41bc2e89 100644
+--- a/xen/arch/x86/arch.mk
++++ b/xen/arch/x86/arch.mk
+@@ -94,7 +94,7 @@ $(shell mkdir -p $(dir $(efi-check)))
+ XEN_BUILD_EFI := $(call if-success,$(CC) $(CFLAGS) -c $(srctree)/$(efi-check).c -o $(efi-check).o,y)
+
+ # Check if the linker supports PE.
+-EFI_LDFLAGS := $(patsubst -m%,-mi386pep,$(LDFLAGS)) --subsystem=10
++EFI_LDFLAGS := -mi386pep $(patsubst -m%,-mi386pep,$(LDFLAGS)) --subsystem=10
+ LD_PE_check_cmd = $(call ld-option,$(EFI_LDFLAGS) --image-base=0x100000000 -o $(efi-check).efi $(efi-check).o)
+ XEN_BUILD_PE := $(LD_PE_check_cmd)
+