summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/2.6.22/20074_xen-x86_64-entry.patch1')
-rw-r--r--trunk/2.6.22/20074_xen-x86_64-entry.patch142
1 files changed, 42 insertions, 0 deletions
diff --git a/trunk/2.6.22/20074_xen-x86_64-entry.patch1 b/trunk/2.6.22/20074_xen-x86_64-entry.patch1
new file mode 100644
index 0000000..914050d
--- /dev/null
+++ b/trunk/2.6.22/20074_xen-x86_64-entry.patch1
@@ -0,0 +1,42 @@
+From: jbeulich@novell.com
+Subject: remove non-native entry point name
+Patch-mainline: obsolete
+
+Index: head-2007-09-03/arch/x86_64/Makefile
+===================================================================
+--- head-2007-09-03.orig/arch/x86_64/Makefile 2007-09-03 09:44:29.000000000 +0200
++++ head-2007-09-03/arch/x86_64/Makefile 2007-09-03 10:02:28.000000000 +0200
+@@ -94,7 +94,7 @@ PHONY += bzImage bzlilo install archmrpr
+ ifdef CONFIG_XEN
+ CPPFLAGS := -Iinclude$(if $(KBUILD_SRC),2)/asm/mach-xen $(CPPFLAGS)
+ head-y := arch/x86_64/kernel/head-xen.o arch/x86_64/kernel/head64-xen.o arch/x86_64/kernel/init_task.o
+-LDFLAGS_vmlinux := -e _start
++LDFLAGS_vmlinux := -e startup_64
+ boot := arch/i386/boot-xen
+ .PHONY: vmlinuz
+ #Default target when executing "make"
+Index: head-2007-09-03/arch/x86_64/kernel/head-xen.S
+===================================================================
+--- head-2007-09-03.orig/arch/x86_64/kernel/head-xen.S 2007-09-03 09:53:50.000000000 +0200
++++ head-2007-09-03/arch/x86_64/kernel/head-xen.S 2007-09-03 10:02:28.000000000 +0200
+@@ -25,11 +25,8 @@
+
+ .section .bootstrap.text, "ax", @progbits
+ .code64
+-#define VIRT_ENTRY_OFFSET 0x0
+-.org VIRT_ENTRY_OFFSET
+ .globl startup_64
+ startup_64:
+-ENTRY(_start)
+ movq $(init_thread_union+THREAD_SIZE-8),%rsp
+
+ /* rsi is pointer to startup info structure.
+@@ -164,7 +161,7 @@ ENTRY(empty_zero_page)
+ .ascii ",ELF_PADDR_OFFSET=0x"
+ utoh __START_KERNEL_map
+ .ascii ",VIRT_ENTRY=0x"
+- utoh (__START_KERNEL_map + __PHYSICAL_START + VIRT_ENTRY_OFFSET)
++ utoh (__START_KERNEL_map + __PHYSICAL_START + startup_64 - .bootstrap.text)
+ .ascii ",HYPERCALL_PAGE=0x"
+ utoh (phys_hypercall_page >> PAGE_SHIFT)
+ .ascii ",FEATURES=writable_page_tables"