summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2015-09-18 00:07:41 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2015-09-18 00:07:41 +0000
commit62df74f195119474ae5e277b8acff255c675d410 (patch)
treebaed89b39379467b6b2b1a32894fb829f5b6252d /www-misc
parentWe don't want a hard dep on dev-db/mysql. (diff)
downloadjmbsvicetto-62df74f195119474ae5e277b8acff255c675d410.tar.gz
jmbsvicetto-62df74f195119474ae5e277b8acff255c675d410.tar.bz2
jmbsvicetto-62df74f195119474ae5e277b8acff255c675d410.zip
Add awstats to my overlay, bump to 7.4 release and add patch to fix the unescaped left brace warnings with perl-5.22.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/awstats/Manifest1
-rw-r--r--www-misc/awstats/awstats-7.4.ebuild112
-rw-r--r--www-misc/awstats/files/awstats-7.1-gentoo.diff21
-rw-r--r--www-misc/awstats/files/awstats-perl-5.22.patch45
-rw-r--r--www-misc/awstats/metadata.xml8
5 files changed, 187 insertions, 0 deletions
diff --git a/www-misc/awstats/Manifest b/www-misc/awstats/Manifest
new file mode 100644
index 0000000..f319cea
--- /dev/null
+++ b/www-misc/awstats/Manifest
@@ -0,0 +1 @@
+DIST awstats-7.4.tar.gz 2936102 SHA256 43abfe7341c2be64f55bb89557347475640ca7ba4473ff30412a3d44358dab55 SHA512 5bce97c71aabeab35e4ff5e5168531e4955d7c1474322c7b4a47d1d06e06ebd0e74d1def73826498e6253f24aeca99309777617b7a914685c927bb6e1c020e1a WHIRLPOOL 8e6872672ec31c73492764414bfbc17ad4b3e295753f301d199d72ccac6df93fcf8969aa792a2de188f20d89a9e4e368f429aa6c9ed38f31ca3415c8fe7899a9
diff --git a/www-misc/awstats/awstats-7.4.ebuild b/www-misc/awstats/awstats-7.4.ebuild
new file mode 100644
index 0000000..6ea9bca
--- /dev/null
+++ b/www-misc/awstats/awstats-7.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+MY_P=${PN}-${PV%_p*}
+
+DESCRIPTION="AWStats is short for Advanced Web Statistics"
+HOMEPAGE="http://www.awstats.org/"
+
+if [ ${MY_P} != ${P} ]; then
+ SRC_URI="https://dev.gentoo.org/~flameeyes/awstats/${P}.tar.gz"
+ # The following SRC_URI is useful only when fetching for the first time
+ # after bump; upstream does not bump the version when they change it, so
+ # we rename it to include the date and upload to our mirrors instead.
+ #SRC_URI="http://www.awstats.org/files/${MY_P}.tar.gz -> ${P}.tar.gz"
+else
+ SRC_URI="http://www.awstats.org/files/${P}.tar.gz"
+fi
+
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="geoip ipv6"
+
+SLOT="0"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ virtual/perl-Time-Local
+ dev-perl/URI
+ geoip? ( dev-perl/Geo-IP )
+ ipv6? ( dev-perl/Net-IP dev-perl/Net-DNS )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.1-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-perl-5.22.patch
+
+ # change default installation directory
+ find . -type f -exec sed \
+ -e "s#/usr/local/awstats/wwwroot#/usr/share/awstats/wwwroot#g" \
+ -e '/PossibleLibDir/s:(.*):("/usr/share/awstats/wwwroot/cgi-bin/lib"):' \
+ -i {} + || die "find/sed failed"
+
+ # set default values for directories; use apache log as an example
+ sed \
+ -e "s|^\(LogFile=\).*$|\1\"/var/log/apache2/access_log\"|" \
+ -e "s|^\(SiteDomain=\).*$|\1\"localhost\"|" \
+ -e "s|^\(DirIcons=\).*$|\1\"/awstats/icon\"|" \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+
+ # enable plugins
+
+ if use ipv6; then
+ sed -e "s|^#\(LoadPlugin=\"ipv6\"\)$|\1|" \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+ fi
+
+ if use geoip; then
+ sed -e '/LoadPlugin="geoip /aLoadPlugin="geoip GEOIP_STANDARD /usr/share/GeoIP/GeoIP.dat"' \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+ fi
+
+ find "${S}" '(' -type f -not -name '*.pl' ')' -exec chmod -x {} + || die
+}
+
+src_install() {
+ dohtml -r docs/*
+ dodoc README.md
+ newdoc wwwroot/cgi-bin/plugins/example/example.pm example_plugin.pm
+ dodoc -r tools/xslt
+
+ keepdir /var/lib/awstats
+
+ insinto /etc/awstats
+ doins "${S}"/wwwroot/cgi-bin/awstats.model.conf
+
+ # remove extra content that we don't want to install
+ rm -r "${S}"/wwwroot/cgi-bin/awstats.model.conf \
+ "${S}"/wwwroot/classes/src || die
+
+ insinto /usr/share/awstats
+ doins -r wwwroot
+ chmod +x "${D}"/usr/share/awstats/wwwroot/cgi-bin/*.pl
+
+ cd "${S}"/tools
+ dobin awstats_buildstaticpages.pl awstats_exportlib.pl \
+ awstats_updateall.pl
+ newbin logresolvemerge.pl awstats_logresolvemerge.pl
+ newbin maillogconvert.pl awstats_maillogconvert.pl
+ newbin urlaliasbuilder.pl awstats_urlaliasbuilder.pl
+
+ dosym ../share/awstats/wwwroot/cgi-bin/awstats.pl /usr/bin/awstats.pl || die
+}
+
+pkg_postinst() {
+ elog "The AWStats-Manual is available either inside"
+ elog "the /usr/share/doc/${PF} - folder, or at"
+ elog "http://awstats.sourceforge.net/docs/index.html ."
+ elog
+ elog "Copy the /etc/awstats/awstats.model.conf to"
+ elog "/etc/awstats/awstats.<yourdomain>.conf and edit it."
+ elog ""
+ ewarn "This ebuild does no longer use webapp-config to install"
+ ewarn "instead you should point your configuration to the stable"
+ ewarn "directory tree in the following path:"
+ ewarn " /usr/share/awstats"
+}
diff --git a/www-misc/awstats/files/awstats-7.1-gentoo.diff b/www-misc/awstats/files/awstats-7.1-gentoo.diff
new file mode 100644
index 0000000..a58ed48
--- /dev/null
+++ b/www-misc/awstats/files/awstats-7.1-gentoo.diff
@@ -0,0 +1,21 @@
+--- awstats-6.3.orig/tools/awstats_configure.pl 2005-01-24 09:28:43.980923725 -0500
++++ awstats-6.3/tools/awstats_configure.pl 2005-01-24 09:28:52.034571769 -0500
+@@ -658,6 +658,18 @@
+ print "\n-----> Restart Web server with '$command'\n";
+ my $ret=`$command`;
+ print "$ret";
++ } elsif (-f "/etc/gentoo-release") {
++ my $command;
++ if (-x "/etc/init.d/apache2") {
++ $command="/etc/init.d/apache2 graceful";
++ } else {
++ print "\n-----> Don't forget to restart manually your web server\n";
++ }
++ if ($command != "") {
++ print "\n-----> Restart Web server with '$command'\n";
++ my $ret=`$command`;
++ print "$ret";
++ }
+ } elsif (-x "/sbin/service") {
+ # We are not on debian
+ my $command="/sbin/service httpd restart";
diff --git a/www-misc/awstats/files/awstats-perl-5.22.patch b/www-misc/awstats/files/awstats-perl-5.22.patch
new file mode 100644
index 0000000..8f4e1ca
--- /dev/null
+++ b/www-misc/awstats/files/awstats-perl-5.22.patch
@@ -0,0 +1,45 @@
+From 6ca56baf8e5819787c128e5ccd741701cb84bfdd Mon Sep 17 00:00:00 2001
+From: Laurent Destailleur <eldy@destailleur.fr>
+Date: Tue, 18 Aug 2015 20:41:20 +0200
+Subject: [PATCH] Compatibility with Perl 5.22
+
+---
+ docs/awstats_changelog.txt | 1 +
+ wwwroot/cgi-bin/awstats.pl | 12 ++++++------
+ 2 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/docs/awstats_changelog.txt b/docs/awstats_changelog.txt
+index 1fcca7f..1b5e342 100644
+--- a/docs/awstats_changelog.txt
++++ b/docs/awstats_changelog.txt
+@@ -8,6 +8,7 @@ New features:
+ option nboflastupdatelookuptosave on command line.
+ - #199 Added geoip6 plugin with support for IPv4 AND IPv6.
+ - Work with Amazon AWS log files (using %time5 tag).
++- Compatibility with Perl 5.22
+
+ Fixes:
+ - Fixes permission on some .pl scripts.
+diff --git a/wwwroot/cgi-bin/awstats.pl b/wwwroot/cgi-bin/awstats.pl
+index c9dcee9..eb14fc0 100755
+--- a/wwwroot/cgi-bin/awstats.pl
++++ b/wwwroot/cgi-bin/awstats.pl
+@@ -9040,12 +9040,12 @@ sub DefinePerlParsingFormat {
+ $LogFormatString =~ s/%>s/%code/g;
+ $LogFormatString =~ s/%b(\s)/%bytesd$1/g;
+ $LogFormatString =~ s/%b$/%bytesd/g;
+- $LogFormatString =~ s/\"%{Referer}i\"/%refererquot/g;
+- $LogFormatString =~ s/\"%{User-Agent}i\"/%uaquot/g;
+- $LogFormatString =~ s/%{mod_gzip_input_size}n/%gzipin/g;
+- $LogFormatString =~ s/%{mod_gzip_output_size}n/%gzipout/g;
+- $LogFormatString =~ s/%{mod_gzip_compression_ratio}n/%gzipratio/g;
+- $LogFormatString =~ s/\(%{ratio}n\)/%deflateratio/g;
++ $LogFormatString =~ s/\"%\{Referer}i\"/%refererquot/g;
++ $LogFormatString =~ s/\"%\{User-Agent}i\"/%uaquot/g;
++ $LogFormatString =~ s/%\{mod_gzip_input_size}n/%gzipin/g;
++ $LogFormatString =~ s/%\{mod_gzip_output_size}n/%gzipout/g;
++ $LogFormatString =~ s/%\{mod_gzip_compression_ratio}n/%gzipratio/g;
++ $LogFormatString =~ s/\(%\{ratio}n\)/%deflateratio/g;
+
+ # Replacement for a IIS and ISA format string
+ $LogFormatString =~ s/cs-uri-query/%query/g; # Must be before cs-uri
diff --git a/www-misc/awstats/metadata.xml b/www-misc/awstats/metadata.xml
new file mode 100644
index 0000000..575c9a5
--- /dev/null
+++ b/www-misc/awstats/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>jmbsvicetto@gentoo.org</email>
+ <name>Jorge Manuel B. S. Vicetto</name>
+</maintainer>
+</pkgmetadata>