summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-10 08:50:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-10 09:06:10 +0200
commit27905908646b97c94534ca30bdd7b5db0117be92 (patch)
tree84a849593d878ff0a7af974a6f5f6dc8ebb7e70e
parentdev-python/tekore: Bump to 5.5.1 (diff)
downloadgentoo-27905908646b97c94534ca30bdd7b5db0117be92.tar.gz
gentoo-27905908646b97c94534ca30bdd7b5db0117be92.tar.bz2
gentoo-27905908646b97c94534ca30bdd7b5db0117be92.zip
dev-python/ansible-compat: Bump to 24.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-24.9.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 8538923ad3c4..631883ed7489 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
DIST ansible-compat-24.8.0.gh.tar.gz 74341 BLAKE2B ce6edf8ed532815f2e307ac51eef0ac694805b0d5f8cad78c75c57478a21eb443348d636ca0e405fe63d32daf0f426c20e0f97183082f0eba3dd4b889fb8be80 SHA512 07da3a5d4f6eaa6edec3a03107d6e751e9754a84420a9839239d17811de01e8c70bed84e8c23a1308d18e8388581b0e269ae03c235bbc244e95a29c3be25567b
+DIST ansible-compat-24.9.0.gh.tar.gz 75290 BLAKE2B 0482d9eba967d4d846e35f3a2754410e1f42d34e451b2cf42bcbb88155fdf90859b9fbf6ead28a6e8c252d3a37522c1d1c903a38d4e47ba427678bc39d3c8e9c SHA512 e6803e598fabb1097bf0f10a7b9592af97152d108bc89a29547546de0eaa87ebba9232e78aeababb3ffd94c58af8b93499de9c059a6c42d04179d02b50d92a0f
diff --git a/dev-python/ansible-compat/ansible-compat-24.9.0.ebuild b/dev-python/ansible-compat/ansible-compat-24.9.0.ebuild
new file mode 100644
index 000000000000..18c39cfc27c2
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-24.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="
+ https://pypi.org/project/ansible-compat/
+ https://github.com/ansible/ansible-compat/
+"
+# We normally use PyPI here but 4.1.12 has never been uploaded there for some reason
+SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.14[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.6.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.4.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+ # pip, failing due to internets
+ test/test_runtime_scan_path.py::test_scan_sys_path
+ # internets?
+ test/test_runtime.py::test_runtime_has_playbook
+)
+
+distutils_enable_tests pytest