summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-04-22 09:28:48 -0400
committerSam James <sam@gentoo.org>2024-05-03 12:52:35 +0100
commit2b9877bf92ffeeaf4825fec7848d349112487929 (patch)
tree546b922d4cceb7245516dece8a8136245fcd91a5
parentgnuconfig.eclass: drop EAPI 5 support (diff)
downloadgentoo-2b9877bf92ffeeaf4825fec7848d349112487929.tar.gz
gentoo-2b9877bf92ffeeaf4825fec7848d349112487929.tar.bz2
gentoo-2b9877bf92ffeeaf4825fec7848d349112487929.zip
net-analyzer/cacti: add 1.2.26, security bump
Bug: https://bugs.gentoo.org/884799 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/36356 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-analyzer/cacti/Manifest1
-rw-r--r--net-analyzer/cacti/cacti-1.2.26.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 89938bf84fc4..28480b1c97a6 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1 +1,2 @@
DIST cacti-1.2.21.tar.gz 40798454 BLAKE2B 86eae6743c07e45b4b06202cca072a385f45d2021159f0f5160a8c2a8eb8f3a2f9db63512515602d1c3eb6be4b53f5755c20d6da2194ff445c133a2bcdb33e27 SHA512 084ff9135dd0a92596a4d65f2fd461c8e84907ff87e467f6d144ee3b52ef7aeb44ffa5a8c25e74e5ff25588bc6c5b13b44ab2f24ef5e1c6652513b5c2a39f78d
+DIST cacti-1.2.26.tar.gz 43637358 BLAKE2B 862b98e9b194f211a400b37f90c2bfb128bf71ee4660391ba2311deedd8b1342ce0d17d67181d16deae345c12596d7599b1272272b32fd7ab52fe2850f8209f6 SHA512 43bfa2fa5b87267191f845de8be38025b795509eb12817e5ff9884b20676655ec4e5230e015abe2afa9f10354317eec39081613e5c9fec4f6a6f314bedf873ab
diff --git a/net-analyzer/cacti/cacti-1.2.26.ebuild b/net-analyzer/cacti/cacti-1.2.26.ebuild
new file mode 100644
index 000000000000..711ac1952fbe
--- /dev/null
+++ b/net-analyzer/cacti/cacti-1.2.26.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edos2unix webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="https://www.cacti.net/"
+SRC_URI="https://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,pdo,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_compile() { :; }
+
+src_install() {
+ dodoc CHANGELOG
+ dodoc -r docs
+ mv docs .. || die
+
+ webapp_src_preinst
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${ED}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}