summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-18 05:01:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-18 05:14:50 +0200
commit414c64571c94bfccb973705373407c8cc0df7a24 (patch)
tree4ccfbd9c2dd94a085a168659ef4b8ab3721d15a1
parentdev-python/sentry-sdk: Bump to 1.23.1 (diff)
downloadgentoo-414c64571c94bfccb973705373407c8cc0df7a24.tar.gz
gentoo-414c64571c94bfccb973705373407c8cc0df7a24.tar.bz2
gentoo-414c64571c94bfccb973705373407c8cc0df7a24.zip
dev-python/keystoneauth1: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/keystoneauth1/Manifest1
-rw-r--r--dev-python/keystoneauth1/keystoneauth1-5.2.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/keystoneauth1/Manifest b/dev-python/keystoneauth1/Manifest
index 95c3a3303569..e3565c078e57 100644
--- a/dev-python/keystoneauth1/Manifest
+++ b/dev-python/keystoneauth1/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-5.1.2.tar.gz 269860 BLAKE2B 3c2d83c20991479b05675ce391357c26e4da2a2434f515a15aa900fe398f6fb5ae383cf6b4068a1205e49813406f632bdfe9490c435d5a8290b92c3dc0bdda8f SHA512 ff7e08114cc76d648c3879f44bb78b51e906fed2d34a9cf3e42199f1c5fc53394ad7b53f6cdfcb336436c482755d54891666369a0832ef9b846dd33dc4821791
+DIST keystoneauth1-5.2.0.tar.gz 273102 BLAKE2B ed05830fad8432c36bff41b2238f91cea69846074da9991e28d75ac2ea00744f811edf33f84a2b3e4b4476de1dee8ecf85cfc7d6dbb01ab733d48a84bed80646 SHA512 4a9818922a7f899ebfb2f80a1cde4e4e62a94c30788f7e79004a24de8f94c7d9e0ce9e15eb3a37137240bb4ae0dcc71620edc7bdc05f83323939a48a075b6031
diff --git a/dev-python/keystoneauth1/keystoneauth1-5.2.0.ebuild b/dev-python/keystoneauth1/keystoneauth1-5.2.0.ebuild
new file mode 100644
index 000000000000..b0f8223e4c1a
--- /dev/null
+++ b/dev-python/keystoneauth1/keystoneauth1-5.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud"
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+HOMEPAGE="
+ https://opendev.org/openstack/keystoneauth/
+ https://github.com/openstack/keystoneauth/
+ https://pypi.org/project/keystoneauth1/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/betamax-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/requests-kerberos-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # relies on specific test runner name
+ sed -i -e 's:run\.py:unittest_or_fail.py:' \
+ keystoneauth1/tests/unit/test_session.py || die
+ # remove the test that requires hacking
+ rm keystoneauth1/tests/unit/test_hacking_checks.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ eunittest -b
+}