summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2022-07-05 17:05:30 +0200
committerSam James <sam@gentoo.org>2022-07-15 02:45:24 +0100
commit4ba7f8cc3f3802f83f192d7d35291fd89e23d7d8 (patch)
treedf08ec763fd25817db74c8d11fda158799cce356
parentgames-util/gamemode: Fix build on musl (diff)
downloadgentoo-4ba7f8cc3f3802f83f192d7d35291fd89e23d7d8.tar.gz
gentoo-4ba7f8cc3f3802f83f192d7d35291fd89e23d7d8.tar.bz2
gentoo-4ba7f8cc3f3802f83f192d7d35291fd89e23d7d8.zip
net-misc/dahdi-tools: rev-bump to fix two bugs
The latter was fixed, then I didn't focus properly when updating for T1 support. Closes: https://bugs.gentoo.org/855467 Closes: https://bugs.gentoo.org/855464 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Closes: https://github.com/gentoo/gentoo/pull/26232 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/dahdi-tools/dahdi-tools-3.1.0-r4.ebuild (renamed from net-misc/dahdi-tools/dahdi-tools-3.1.0-r3.ebuild)6
-rw-r--r--net-misc/dahdi-tools/files/dahdi-autoconf.init-3.1.0-r4 (renamed from net-misc/dahdi-tools/files/dahdi-autoconf.init-3.1.0-r3)10
2 files changed, 10 insertions, 6 deletions
diff --git a/net-misc/dahdi-tools/dahdi-tools-3.1.0-r3.ebuild b/net-misc/dahdi-tools/dahdi-tools-3.1.0-r4.ebuild
index 4cdea940512c..4ccf762c64d7 100644
--- a/net-misc/dahdi-tools/dahdi-tools-3.1.0-r3.ebuild
+++ b/net-misc/dahdi-tools/dahdi-tools-3.1.0-r4.ebuild
@@ -54,7 +54,7 @@ src_install() {
# install init scripts
newinitd "${FILESDIR}"/dahdi.init2 dahdi
- newinitd "${FILESDIR}"/dahdi-autoconf.init-3.1.0-r3 dahdi-autoconf
+ newinitd "${FILESDIR}"/dahdi-autoconf.init-3.1.0-r4 dahdi-autoconf
newconfd "${FILESDIR}"/dahdi-autoconf.conf2 dahdi-autoconf
bashcomp_alias dahdi $(sed -nre 's/^complete -F .* //p' "${ED}${bashcompdir}/dahdi" ||
@@ -68,3 +68,7 @@ src_install() {
pkg_postinst() {
udev_reload
}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/net-misc/dahdi-tools/files/dahdi-autoconf.init-3.1.0-r3 b/net-misc/dahdi-tools/files/dahdi-autoconf.init-3.1.0-r4
index 3841aca8d18a..73ab07b8904f 100644
--- a/net-misc/dahdi-tools/files/dahdi-autoconf.init-3.1.0-r3
+++ b/net-misc/dahdi-tools/files/dahdi-autoconf.init-3.1.0-r4
@@ -150,20 +150,20 @@ dahdi_conf_span() {
case "${type}" in
digital-TE)
- cfunc+="bri_te"
+ cfunc="${cfunc}bri_te"
;;
digital-NT)
- cfunc+="bri_nt"
+ cfunc="${cfunc}bri_nt"
;;
digital-[TE]1)
- cfunc+="$(echo "${type##*-}" | tr 'TE' 'te')"
+ cfunc="${cfunc}$(echo "${type##*-}" | tr 'TE' 'te')"
# Use CPE by default. Unfortunately there is no easy
# way to detect CPE vs NET as far as I know and specifying
# in a config that you want NET mode seems the sanest way.
if yesno "${vname}"; then
- cfunc+="_net"
+ cfunc="${cfunc}_net"
else
- cfunc+="_cpe"
+ cfunc="${cfunc}_cpe"
fi
;;
*)