summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-08-09 16:30:55 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-08-09 16:31:33 +0200
commit4d69dc3cf5d538dbdfbe80affbfa484c6c5bd4c4 (patch)
tree2ec0209f1a50e3ef271ba6563433e7f794a422f3
parentwww-client/chromium: remove old patches (diff)
downloadgentoo-4d69dc3cf5d538dbdfbe80affbfa484c6c5bd4c4.tar.gz
gentoo-4d69dc3cf5d538dbdfbe80affbfa484c6c5bd4c4.tar.bz2
gentoo-4d69dc3cf5d538dbdfbe80affbfa484c6c5bd4c4.zip
net-analyzer/prometheus: Version bump to 2.0.0_beta0
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.0.0_beta0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index 428e43232564..3ce346c0e6b7 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1 +1,2 @@
DIST prometheus-1.7.1.tar.gz 5122747 SHA256 209832310f5bef99faef3beaaa95263612a4d0126ca512c4a4c23a8543d3ccf5 SHA512 98a42e95978477530082d7549c29f17b133043d7c233ba3c90b183f06a3f24ee578f8fed75cba476d3c93a22abcccfdbccc94488beb8450a02f260d24165ba26 WHIRLPOOL 8ab473430752336e09b4a0c38fd1117abe21196478d7f2f7e813c27f07c950cc3525d9e9ba32309711c73a1032f3cff27ddc1582d0c4b6c66fe82d5b58675550
+DIST prometheus-2.0.0_beta0.tar.gz 5475399 SHA256 7463ff35335ff7fee05018234aa1d100ef78e10f8c549e23675a7552b0429f77 SHA512 f9da91cbe4e7d5510088e09c8457b08bcfe6a4e0ef781e33a848bbd78045f46042e9a55c4329b71dec4cb11143566de2d077fa34361da3eb66af19f8261baab8 WHIRLPOOL 854010b6d9c86688311c992f644cb51c3b0d50523702fc4d82814f92400a141e9557fe367e47aafd2ae2628a73b6533627fab49b1a7f69bbe36081e2c8193f0e
diff --git a/net-analyzer/prometheus/prometheus-2.0.0_beta0.ebuild b/net-analyzer/prometheus/prometheus-2.0.0_beta0.ebuild
new file mode 100644
index 000000000000..c8412fb071ed
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.0.0_beta0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_beta/-beta.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="2b5d915"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}