summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 21:00:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 21:05:45 +0100
commit674d35ec7329fbbb46384a246ec6668d046b96a1 (patch)
treef8443ab5ca6c390499b968eb24577139a49029dc
parentdev-python/deepdiff: Bump to 6.7.1 (diff)
downloadgentoo-674d35ec7329fbbb46384a246ec6668d046b96a1.tar.gz
gentoo-674d35ec7329fbbb46384a246ec6668d046b96a1.tar.bz2
gentoo-674d35ec7329fbbb46384a246ec6668d046b96a1.zip
dev-python/phonenumbers: Bump to 8.13.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/phonenumbers/Manifest1
-rw-r--r--dev-python/phonenumbers/phonenumbers-8.13.25.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/Manifest b/dev-python/phonenumbers/Manifest
index 713393d2ee41..bc7157b210c5 100644
--- a/dev-python/phonenumbers/Manifest
+++ b/dev-python/phonenumbers/Manifest
@@ -1 +1,2 @@
DIST python-phonenumbers-8.13.24.gh.tar.gz 4916204 BLAKE2B e283c7eb8e3936f6affc82f4e884e74f8f29b1ea43f9a5f3ab200b882d0a153cac9d199b0e44a6ca54098591f7044a92b82eb5cd254ca6d29439d18f3d2d6a7f SHA512 de11794c3e1ea8823a1e4fa0e998fd9657f4ebf4d187bd59e361bb0cb24cb771595ceb99e9ae4fb14e2ea0bb4058bacc13abce6dc6837911abbf7db5ceec0db2
+DIST python-phonenumbers-8.13.25.gh.tar.gz 4915568 BLAKE2B 2c547c41f6d7544dd243ae5149e8b90d4a7fa6e29c2e809bd682fb31027d863878ef9a5c7331f967c2f7da824b0dde9447527b8f15a4517533ce8dfb9f7b4285 SHA512 416363cfcbdf1eb0f32cac1141720208fc198f810190e1b79403121ff1f77bf66570ca0b5ea3e2197994dc5408af040a045dbfcc241fec70c63146f05b24474b
diff --git a/dev-python/phonenumbers/phonenumbers-8.13.25.ebuild b/dev-python/phonenumbers/phonenumbers-8.13.25.ebuild
new file mode 100644
index 000000000000..e686a889cbea
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-8.13.25.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="
+ https://github.com/daviddrysdale/python-phonenumbers/
+ https://pypi.org/project/phonenumbers/
+"
+SRC_URI="
+ https://github.com/daviddrysdale/python-phonenumbers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( ../README.md )
+
+python_test() {
+ "${EPYTHON}" testwrapper.py -v || die "Tests failed with ${EPYTHON}"
+}