summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-03-24 00:26:30 +1300
committerKent Fredric <kentnl@gentoo.org>2017-03-24 00:26:49 +1300
commit6f9e560f5b428f52f50e2cf788dbd6c71b879323 (patch)
tree0edaa7fa252dd5b621ec6c19b7f7066fc1213745
parentdev-perl/Log-Log4perl: Remove old (diff)
downloadgentoo-6f9e560f5b428f52f50e2cf788dbd6c71b879323.tar.gz
gentoo-6f9e560f5b428f52f50e2cf788dbd6c71b879323.tar.bz2
gentoo-6f9e560f5b428f52f50e2cf788dbd6c71b879323.zip
dev-perl/DBD-mysql: Bump to version 4.42.0 re bug #604678
Upstream: - Fix encoding of input statements with mysql_enable_utf8 and mysql_enable_utf8mb4 - Set UTF-8 flag for decoded data - Return INTs with ZEROFILL as strings - Statement handle how has mysql_sock attribute - Fixed type conversions for magic types - Fix UTF8 encoding of table/field names and warnings/errors - Fix mysql_auto_reconnect with mysql_server_prepare - Improve regex for removing database from dsn - Locate libmysql with Devel::CheckLib - Support async on windows - Fix tests against older Mysql/Mariadb - Fix compilation with Mysql 4.1 - Don't leak dangling pointer to mysql result - Fix logic assigning to variable bind_comment_placeholders - fix mysql_fd returning fd after connection closed. - Fix parsing configure libs from mysql_config - Fix support for magic scalars Keywording: - New dependencies necessitate dropping: ia64 mips ppc64 sparc x86-fbsd Bug: https://bugs.gentoo.org/604678 Package-Manager: Portage-2.3.4, Repoman-2.3.2
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild66
-rw-r--r--dev-perl/DBD-mysql/Manifest1
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
new file mode 100644
index 000000000000..91fa6f7a5e09
--- /dev/null
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.42.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MICHIELB
+DIST_VERSION=4.042
+inherit eutils perl-module
+
+DESCRIPTION="MySQL driver for the Perl5 Database Interface (DBI)"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~s390 ~sh ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# embedded=on disables ssl support
+# https://metacpan.org/source/MICHIELB/DBD-mysql-4.036/dbdimp.c#L1886
+REQUIRED_USE="?? ( embedded ssl )"
+IUSE="embedded test +ssl"
+
+RDEPEND=">=dev-perl/DBI-1.609.0
+ virtual/libmysqlclient:=
+ embedded? ( virtual/mysql[embedded] )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Data-Dumper
+ dev-perl/Devel-CheckLib
+ test? (
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.900.0
+ virtual/perl-Time-HiRes
+ )
+"
+
+src_configure() {
+ if use test; then
+ myconf="${myconf} --testdb=test \
+ --testhost=localhost \
+ --testuser=test \
+ --testpassword=test"
+ fi
+ myconf="${myconf} --$(usex ssl ssl nossl)"
+ use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
+ perl-module_src_configure
+}
+
+# Parallel testing is broken as 2 tests create the same table
+# and mysql isn't acid compliant and can't limit visibility of tables
+# to a transaction...
+DIST_TEST="do"
+
+src_test() {
+ einfo
+ einfo "If tests fail, you have to configure your MySQL instance to create"
+ einfo "and grant some privileges to the test user."
+ einfo "You can run the following commands at the MySQL prompt: "
+ einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+ einfo "> CREATE DATABASE test;"
+ einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+ einfo
+ sleep 5
+ perl_rm_files t/pod.t t/manifest.t
+ # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
+ # out why 60leaks.t fails
+ perl-module_src_test
+}
diff --git a/dev-perl/DBD-mysql/Manifest b/dev-perl/DBD-mysql/Manifest
index 3d190ff8cbd7..357e81527cd0 100644
--- a/dev-perl/DBD-mysql/Manifest
+++ b/dev-perl/DBD-mysql/Manifest
@@ -1,3 +1,4 @@
DIST DBD-mysql-4.032.tar.gz 146476 SHA256 b8e681e719d8f2d1cecb9e8603e13483b09b56508629b079022778e7dfd7bfb6 SHA512 7e7ebaed07f0540079854294cc3ab4a4554fd0f850dd0927b2485cc985c2c9f5b70a650d971027c883cc4d8450020245656f6ff1f792a56d1a2d4b45402d73d0 WHIRLPOOL 79b94c7c85406e0f3a0469c8017594f81f6151eab3059d483c50326222fdb920d12db04a5382dbdc2862cf853e1c421fe0d7acc4a35b131a0f9d39c2d79f5d0b
DIST DBD-mysql-4.037.tar.gz 146639 SHA256 df578acef28ed3f6aaae52dc98e6821a1407d3bfa88585255729bb0ebfed3cfc SHA512 3bda6ea18d29e32028b7eb93cd06fdbabbadafa66f982556298a68980c42a7b5236872113696e6d2df66a345049d1e63bc90ab358c8631f0cbea187780e514af WHIRLPOOL 2cd51fb258de4877010d6d5f88a27f8e251d86b311d5d7dc3b62a46e7d6ac87facaad7c2bbba6c7f306d91d106e7a713fb21c2f1b7d2934e989aa30794d38a7f
DIST DBD-mysql-4.041.tar.gz 150508 SHA256 4777de11c464b515db9da95c08c225900d0594b65ba3256982dc21f9f9379040 SHA512 8663c58f1dec273869ef5d3ee663d80cb36fa87b1956318fff07a4a801aaecc395510a8f31b7a51b823f7e9d6a73ebf13894c1b7f7b27fdc3f3956e6aba34777 WHIRLPOOL 9440ce5e595091228512dbdc90f13dfa9fd0133ba82c96f2be993cec545479c89e362b923ca973829982aca0e81fede30833d32b3c02d4a25287caea31bce47e
+DIST DBD-mysql-4.042.tar.gz 160028 SHA256 dadb6884788dc3fdf40b13b72d8c60d5a83680cc2aeec7515c3e5999e064b455 SHA512 fe3c9e1e325f7056da783e0ea33f9a7810f25f3d9cd2c9a4bf4037b20a2148f2291b2f90d44730e63c7902b45e26993a7f9fcf1b3bf8d1bc5d3fca99893a019e WHIRLPOOL e8fe5c142028df4b10982f71e4aede68f01e0ecef6040fb6d4cf0d8006ab34f80fa8d20fd06794c2668dc8cb0a0459a8c97038f3abe280a6f6bd94e4d04f216f