summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-22 20:33:15 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-22 20:34:30 -0700
commit770c628cd7816387f593df6ab36d9f06ce4fdbc9 (patch)
treecdad4b1fea0c46bd70cbc68cdbad833f3700689e
parentdev-lang/rust: add 1.64.0 (diff)
downloadgentoo-770c628cd7816387f593df6ab36d9f06ce4fdbc9.tar.gz
gentoo-770c628cd7816387f593df6ab36d9f06ce4fdbc9.tar.bz2
gentoo-770c628cd7816387f593df6ab36d9f06ce4fdbc9.zip
virtual/rust: add 1.64.0
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--virtual/rust/rust-1.64.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.64.0.ebuild b/virtual/rust/rust-1.64.0.ebuild
new file mode 100644
index 000000000000..b7da1d054aa3
--- /dev/null
+++ b/virtual/rust/rust-1.64.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"