summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2017-08-06 15:33:11 +0200
committerMichael Palimaka <kensington@gentoo.org>2018-01-10 19:44:30 +1100
commit7da16c6b164802d16e6795f3d23a6d2102f46805 (patch)
tree97b671099ced7c8ee783a1f4a952f0e644ca4c67
parentwww-apps/rutorrent: update (R)DEPEND to < php-7 (diff)
downloadgentoo-7da16c6b164802d16e6795f3d23a6d2102f46805.tar.gz
gentoo-7da16c6b164802d16e6795f3d23a6d2102f46805.tar.bz2
gentoo-7da16c6b164802d16e6795f3d23a6d2102f46805.zip
www-apps/rutorrent: version bump to 3.8
taken from https://github.com/doctaweeks/junkdrawer-overlay with slight modification Closes: https://bugs.gentoo.org/490786 Closes: https://github.com/gentoo/gentoo/pull/5322
-rw-r--r--www-apps/rutorrent/Manifest1
-rw-r--r--www-apps/rutorrent/rutorrent-3.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/www-apps/rutorrent/Manifest b/www-apps/rutorrent/Manifest
index b96362e1632a..0dbb3fc35774 100644
--- a/www-apps/rutorrent/Manifest
+++ b/www-apps/rutorrent/Manifest
@@ -1,2 +1,3 @@
DIST plugins-3.4.tar.gz 674444 BLAKE2B ccbd132c5868684b3c25357d85e6aaa27b3e871730b6b64a1fe4dec765a9548be282a1aa98a39efc6b63df0fe1ebcf01ef7b74ea1ca293a636813684f8887406 SHA512 85d9ada4bd07cd50fdf88f4ae1a1bc682b6e54d5600356be73481094111cc21fad6fb2acac4b854ba815f986b3859caf824bc55c5bbac68872db8920e0c5fd9f
DIST rutorrent-3.4.tar.gz 241253 BLAKE2B 7ff5423b36cd9a237b9cb656f65696948f31c1978460d4c17874a5fab6e7f1adf6bf7f5e1f165936913f79350aa6de81dffd929d0c7f406c7f125d36f2f0db43 SHA512 2fee5dd21e0d63fa9059c96ad3e8d09f3ce556adbfd1cb148224af998edcdb82c2fe05cb56daac0cdb8c3d50346536611d019fddb1833b06fa2ebc30cd884a0a
+DIST rutorrent-3.8.tar.gz 1241643 BLAKE2B c432e8691d35447cd0698eee8edeee4060238dc39cc8cbb178c1169f166fa1d483493181ce0d2f468106ae01dd0f58d4fbb2f334de393fabb2b0aa73363e2b7f SHA512 ea3dfa74234a1eafcbc9e71d6c6d953a46fdf8e189237b8df0ec58cf46ac30404f7a15bb783ec7567ab6f28daa3987ee219039dd360e3c48d16aea244263c9b6
diff --git a/www-apps/rutorrent/rutorrent-3.8.ebuild b/www-apps/rutorrent/rutorrent-3.8.ebuild
new file mode 100644
index 000000000000..06d1d6b36e7f
--- /dev/null
+++ b/www-apps/rutorrent/rutorrent-3.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+DESCRIPTION="ruTorrent is a front-end for the popular Bittorrent client rTorrent"
+HOMEPAGE="https://github.com/Novik/ruTorrent"
+SRC_URI="https://github.com/Novik/ruTorrent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+need_httpd_cgi
+
+DEPEND="
+ || ( dev-lang/php[xml,gd] dev-lang/php[xml,gd-external] )
+"
+RDEPEND="virtual/httpd-php"
+
+S="${WORKDIR}/ruTorrent-${PV}"
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ default
+ find -name '\.gitignore' -type f -exec rm -rf {} \;
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ chmod +x "${ED}${MY_HTDOCSDIR}"/plugins/*/*.sh \
+ "$ED${MY_HTDOCSDIR}"/php/test.sh || die "chmod failed"
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/share
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/settings
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/torrents
+ webapp_serverowned "${MY_HTDOCSDIR}"/share/users
+
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/.htaccess
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/config.php
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/access.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/conf/plugins.ini
+ webapp_configfile "${MY_HTDOCSDIR}"/share/.htaccess
+
+ webapp_src_install
+}