summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-13 05:50:05 +0000
committerSam James <sam@gentoo.org>2023-01-13 05:50:05 +0000
commit835163cfa57c3052287ae852ad44df18fff6bacf (patch)
treee36eb980c78ed83347bc63ff951bf61d14ee4782
parentnet-misc/curl: drop 7.87.0 (diff)
downloadgentoo-835163cfa57c3052287ae852ad44df18fff6bacf.tar.gz
gentoo-835163cfa57c3052287ae852ad44df18fff6bacf.tar.bz2
gentoo-835163cfa57c3052287ae852ad44df18fff6bacf.zip
dev-util/bpftool: fix build w/ app-alternatives/tar[libarchive]
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/bpftool/bpftool-5.19.12.ebuild6
-rw-r--r--dev-util/bpftool/bpftool-6.0.12.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/dev-util/bpftool/bpftool-5.19.12.ebuild b/dev-util/bpftool/bpftool-5.19.12.ebuild
index 276c46117bea..aa4096be5d13 100644
--- a/dev-util/bpftool/bpftool-5.19.12.ebuild
+++ b/dev-util/bpftool/bpftool-5.19.12.ebuild
@@ -43,6 +43,7 @@ DEPEND="
BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
${PYTHON_DEPS}
+ app-arch/tar
dev-python/docutils
"
@@ -56,10 +57,9 @@ src_unpack() {
tools/{arch,build,include,lib,perf,scripts} {scripts,include,lib} "arch/*/lib"
)
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
+ # We expect the tar implementation to support the -j and --wildcards option
echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
- tar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
+ gtar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
"${paths[@]/#/linux-${LINUX_VER}/}" || die
if [[ -n ${LINUX_PATCH} ]] ; then
diff --git a/dev-util/bpftool/bpftool-6.0.12.ebuild b/dev-util/bpftool/bpftool-6.0.12.ebuild
index 6833c60b6e2a..35996f352094 100644
--- a/dev-util/bpftool/bpftool-6.0.12.ebuild
+++ b/dev-util/bpftool/bpftool-6.0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ DEPEND="
BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
${PYTHON_DEPS}
+ app-arch/tar
dev-python/docutils
"
@@ -54,10 +55,9 @@ src_unpack() {
tools/{arch,build,include,lib,perf,scripts} {scripts,include,lib} "arch/*/lib"
)
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
+ # We expect the tar implementation to support the -j and --wildcards option
echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
- tar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
+ gtar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
"${paths[@]/#/linux-${LINUX_VER}/}" || die
if [[ -n ${LINUX_PATCH} ]] ; then