summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-13 05:30:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-13 05:31:04 +0100
commit89363b2d1e4c73f68c8f1b1c385ef3902c0e55b8 (patch)
treea8e306be5ceac5fbc8953fe6c19bd6f976848408
parentdev-python/editorconfig: Fix S (diff)
downloadgentoo-89363b2d1e4c73f68c8f1b1c385ef3902c0e55b8.tar.gz
gentoo-89363b2d1e4c73f68c8f1b1c385ef3902c0e55b8.tar.bz2
gentoo-89363b2d1e4c73f68c8f1b1c385ef3902c0e55b8.zip
dev-python/editorconfig: Bump to 0.12.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/editorconfig/Manifest2
-rw-r--r--dev-python/editorconfig/editorconfig-0.12.4.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/editorconfig/Manifest b/dev-python/editorconfig/Manifest
index 163c02aae408..29650a3e2684 100644
--- a/dev-python/editorconfig/Manifest
+++ b/dev-python/editorconfig/Manifest
@@ -1,2 +1,4 @@
DIST editorconfig-core-py-0.12.3.tar.gz 19261 BLAKE2B 58cac122cfee19527bc45def7e923da50982de0e2cd443cf67dd824c050fb12352b85a5679815a701bc5b8d88a089a0a98280c364730086d01b80f119ad996a4 SHA512 005d0698c410c8865d177a1e891b5c51b15255f36303b116fddbbbc08e309d1d60ca3003d27e6fd8455e53c5956db0c29e298f22f4b10950e1f7c56c7c6e0ab3
+DIST editorconfig-core-py-0.12.4.gh.tar.gz 19411 BLAKE2B f1cbcce704efb9a185ff25e2fe800156a02288be389a3908579fbf4ec0131f79fc9a453040d4259fc050e1aa94cfc68f557580c86ca8d7fb65582c32d7a1c6af SHA512 12eea18d0af84eea6f71658781c9f9b58e3490db7056ddc5eae3e0ce3413635eac995e0fdef33a7fe6e2d60649e95a67034a53f304faa38f6022d86fee135464
+DIST editorconfig-core-test-abb579e00f2deeede91cb485e53512efab9c6474.gh.tar.gz 7900 BLAKE2B 9ebdb5e522948bc9e86ea84435ccaa11585a8a12f4cd6fe54c64d78917281c913568351767d8077623b1196d84206d1c2d0126a0510f70df484c1b55d829028b SHA512 ae5424b4926d6cb127cb3da473400ced4f7ccf224f7baa8bc5bde0317cc045bb7b99738a56efe5fd0e5a0fbe39b997b9fb1739d24713e7f83b58e987c5e56a32
DIST editorconfig-core-test-abb579e00f2deeede91cb485e53512efab9c6474.tar.gz 7900 BLAKE2B 9ebdb5e522948bc9e86ea84435ccaa11585a8a12f4cd6fe54c64d78917281c913568351767d8077623b1196d84206d1c2d0126a0510f70df484c1b55d829028b SHA512 ae5424b4926d6cb127cb3da473400ced4f7ccf224f7baa8bc5bde0317cc045bb7b99738a56efe5fd0e5a0fbe39b997b9fb1739d24713e7f83b58e987c5e56a32
diff --git a/dev-python/editorconfig/editorconfig-0.12.4.ebuild b/dev-python/editorconfig/editorconfig-0.12.4.ebuild
new file mode 100644
index 000000000000..849c3cf6df6b
--- /dev/null
+++ b/dev-python/editorconfig/editorconfig-0.12.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit cmake distutils-r1
+
+MY_P=editorconfig-core-py-${PV}
+TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
+DESCRIPTION="Clone of EditorConfig core written in Python"
+HOMEPAGE="https://editorconfig.org/"
+SRC_URI="
+ https://github.com/editorconfig/editorconfig-core-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+ test? (
+ https://github.com/editorconfig/editorconfig-core-test/archive/${TESTVER}.tar.gz
+ -> editorconfig-core-test-${TESTVER}.gh.tar.gz
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="PYTHON BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ !<app-vim/editorconfig-vim-0.3.3-r1
+ cli? ( !app-text/editorconfig-core-c[cli] )
+"
+
+src_prepare() {
+ if use test; then
+ mv "${WORKDIR}"/editorconfig-core-test-${TESTVER}/* "${S}"/tests || die
+ fi
+ if ! use cli; then
+ sed -i -e '/editorconfig\.__main__/d' setup.py || die
+ fi
+
+ cmake_src_prepare
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ )
+
+ cmake_src_configure
+ cmake_src_compile
+ cmake_src_test
+}