summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-27 07:25:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-27 08:10:35 +0200
commit9c3e054cd2ff781bf4a1d3904c045bb83e92dc4d (patch)
tree5209d5674e30595721d36dfab717c18ca0a386d8
parentdev-python/lockfile: Enable py3.11 (diff)
downloadgentoo-9c3e054cd2ff781bf4a1d3904c045bb83e92dc4d.tar.gz
gentoo-9c3e054cd2ff781bf4a1d3904c045bb83e92dc4d.tar.bz2
gentoo-9c3e054cd2ff781bf4a1d3904c045bb83e92dc4d.zip
dev-python/libcloud: Bump to 3.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/libcloud/Manifest1
-rw-r--r--dev-python/libcloud/libcloud-3.6.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/libcloud/Manifest b/dev-python/libcloud/Manifest
index 8f791dbbc161..549a492c2891 100644
--- a/dev-python/libcloud/Manifest
+++ b/dev-python/libcloud/Manifest
@@ -1 +1,2 @@
DIST apache-libcloud-3.5.1.tar.bz2 1859270 BLAKE2B c2e49a79ac4feccb5285d9bf55a4a6e8486d32968216b68e8c8f5b049ef5fa8caae853b4e4cc31ec2c323aedf3de275ab79758b1a055d7f20bbde994c58ba882 SHA512 22d6facf344687bfcfd32e53ede12227882f55bf54ffcf75d5584652c4cd257905c56e359d9c6b050635faa2305c344a6dfdc17007eb41143ccff772bd31d91e
+DIST apache-libcloud-3.6.0.tar.bz2 1873596 BLAKE2B 7ca67d0a84d1af9a216882efb35ff48f4a795eacf34132b78429e0158b1093b3eec316541a52673e61edfc5bfcb326052ee874fe59b1e4a65b407bdaccf38774 SHA512 3a4b4ecf35194e70b6cb70f0619238e1c0140891c08438d4b1ef308fffc9dfb973a5c1534b6ee7864797925b7f7be77eb79a2c4d621627d8042da3927b3f2ff4
diff --git a/dev-python/libcloud/libcloud-3.6.0.ebuild b/dev-python/libcloud/libcloud-3.6.0.ebuild
new file mode 100644
index 000000000000..83c24363bde5
--- /dev/null
+++ b/dev-python/libcloud/libcloud-3.6.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unified Interface to the Cloud - python support libs"
+HOMEPAGE="https://libcloud.apache.org/"
+SRC_URI="mirror://apache/${PN}/apache-${P}.tar.bz2"
+S="${WORKDIR}/apache-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-2.6.1[${PYTHON_USEDEP}]
+ dev-python/lockfile[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ libcloud/test/compute/test_ovh.py::OvhTests::test_list_nodes_invalid_region
+ libcloud/test/test_connection.py::BaseConnectionClassTestCase::test_connection_timeout_raised
+ libcloud/test/test_connection.py::ConnectionClassTestCase::test_retry_on_all_default_retry_exception_classes
+ # TODO
+ libcloud/test/compute/test_ssh_client.py::ParamikoSSHClientTests::test_key_file_non_pem_format_error
+)
+
+src_prepare() {
+ if use examples; then
+ mkdir examples || die
+ mv example_*.py examples || die
+ fi
+
+ # needed for tests
+ cp libcloud/test/secrets.py-dist libcloud/test/secrets.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ use examples && dodoc -r examples
+ distutils-r1_src_install
+}