summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-09-02 02:23:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-02 02:23:21 +0200
commita85bdb42ac21f9adb2ed7b71c6257fbf8a2f60e6 (patch)
treecd530f286893f229b2ce32587e5e6f574006e618
parentdev-lang/php: Version bump to 7.1.9 (diff)
downloadgentoo-a85bdb42ac21f9adb2ed7b71c6257fbf8a2f60e6.tar.gz
gentoo-a85bdb42ac21f9adb2ed7b71c6257fbf8a2f60e6.tar.bz2
gentoo-a85bdb42ac21f9adb2ed7b71c6257fbf8a2f60e6.zip
app-editors/nano: Fixed build with USE="minimal" (bug #629510).
Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--app-editors/nano/files/nano-2.8.7-minimal_compile_fix.patch38
-rw-r--r--app-editors/nano/nano-2.8.7.ebuild6
2 files changed, 43 insertions, 1 deletions
diff --git a/app-editors/nano/files/nano-2.8.7-minimal_compile_fix.patch b/app-editors/nano/files/nano-2.8.7-minimal_compile_fix.patch
new file mode 100644
index 000000000000..ef8d74910164
--- /dev/null
+++ b/app-editors/nano/files/nano-2.8.7-minimal_compile_fix.patch
@@ -0,0 +1,38 @@
+From 28cfab7580c42a6d6c9c5d787ce736094fd51a0c Mon Sep 17 00:00:00 2001
+From: Benno Schulenberg <bensberg@telfort.nl>
+Date: Tue, 29 Aug 2017 19:28:44 +0200
+Subject: tweaks: fix compilation when configured with --enable-tiny
+
+When moving the cursor to the top-left corner, it is not necessary
+to compute leftedge because firstcolumn IS the relevant leftedge.
+
+Reported-by: Jordi Mallach <jordi@debian.org>
+---
+ src/move.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/move.c b/src/move.c
+index d138356..ce276e4 100644
+--- a/src/move.c
++++ b/src/move.c
+@@ -121,7 +121,7 @@ void do_page_up(void)
+ openfile->current = openfile->edittop;
+ openfile->current_y = 0;
+
+- leftedge = leftedge_for(openfile->firstcolumn, openfile->edittop);
++ leftedge = openfile->firstcolumn;
+ target_column = 0;
+ } else
+ get_edge_and_target(&leftedge, &target_column);
+@@ -152,7 +152,7 @@ void do_page_down(void)
+ openfile->current = openfile->edittop;
+ openfile->current_y = 0;
+
+- leftedge = leftedge_for(openfile->firstcolumn, openfile->edittop);
++ leftedge = openfile->firstcolumn;
+ target_column = 0;
+ } else
+ get_edge_and_target(&leftedge, &target_column);
+--
+cgit v1.0-41-gc330
+
diff --git a/app-editors/nano/nano-2.8.7.ebuild b/app-editors/nano/nano-2.8.7.ebuild
index 4463df57a3e0..49a313cd1936 100644
--- a/app-editors/nano/nano-2.8.7.ebuild
+++ b/app-editors/nano/nano-2.8.7.ebuild
@@ -31,11 +31,15 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
static? ( ${LIB_DEPEND} )"
+PATCHES=(
+ "${FILESDIR}/${P}-minimal_compile_fix.patch" #629510
+)
+
src_prepare() {
+ default
if [[ ${PV} == "9999" ]] ; then
eautoreconf
fi
- default
}
src_configure() {