summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2017-01-19 20:11:52 +0000
committerDavid Seifert <soap@gentoo.org>2017-01-20 10:57:40 +0100
commita86031ea832f089e34eb518858d1df8d9c426655 (patch)
tree0a4669e2fa80bbca28b38926f7b2625f1d1ce837
parentmedia-libs/libass: x86 stable wrt bug #596422 (diff)
downloadgentoo-a86031ea832f089e34eb518858d1df8d9c426655.tar.gz
gentoo-a86031ea832f089e34eb518858d1df8d9c426655.tar.bz2
gentoo-a86031ea832f089e34eb518858d1df8d9c426655.zip
x11-misc/menumaker: bump to 0.99.10
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3547
-rw-r--r--x11-misc/menumaker/Manifest1
-rw-r--r--x11-misc/menumaker/files/menumaker-0.99.10-AM_PATH_PYTHON.patch100
-rw-r--r--x11-misc/menumaker/menumaker-0.99.10.ebuild59
3 files changed, 160 insertions, 0 deletions
diff --git a/x11-misc/menumaker/Manifest b/x11-misc/menumaker/Manifest
index d3cf5a6cfaee..cae100289f5a 100644
--- a/x11-misc/menumaker/Manifest
+++ b/x11-misc/menumaker/Manifest
@@ -1 +1,2 @@
+DIST menumaker-0.99.10.tar.gz 202580 SHA256 7e22db0f0d937d33bb338e03f6eac9aa549b9a790c666e519b13de39de66a4d6 SHA512 e7a731ac848089cbdb845fdb0e344b48e70d3bb7220870127d3616549d31fa62b61a48e3efff52d7767b597a4407a8548e776c16976072d0aa7f5c96740cd207 WHIRLPOOL 25db03310dd3847ad419d7e47c4a7e39e527b383027af889292ae693187e72360f3bdf4d77e25d42091945dc277f95562e9bdc43ba84b38e4530bf03914d5ac3
DIST menumaker-0.99.9.tar.gz 177303 SHA256 653361fa8d739e0adba788f187ae2545e0a9c510fd7544c31b7fbc25e87e0e2f SHA512 57ee20f61be366836270170d452f8e9e77cd9fe2abe2e6e0bb5f630d6e328ff4445b95135f4820c2cf80408f629dc801741f8c4bd19b1f12446367b225299229 WHIRLPOOL fe48bef65fe299d8ab0930c90e6b82710e89cf36f02e9705fd5ccdb54372b4870e954161a8cc0c07232aa0cddf8bd98ae95b7279d21bbb2e274b32d3b3a73f57
diff --git a/x11-misc/menumaker/files/menumaker-0.99.10-AM_PATH_PYTHON.patch b/x11-misc/menumaker/files/menumaker-0.99.10-AM_PATH_PYTHON.patch
new file mode 100644
index 000000000000..8e645a8b2fbc
--- /dev/null
+++ b/x11-misc/menumaker/files/menumaker-0.99.10-AM_PATH_PYTHON.patch
@@ -0,0 +1,100 @@
+Use AM_PATH_PYTHON instead of broken hacks
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,23 +1,13 @@
+-AC_INIT(MenuMaker, 0.99.10)
++AC_INIT([MenuMaker], [0.99.10])
+
+ AM_INIT_AUTOMAKE
+
+-#AZ_PYTHON_DEFAULT
++AM_PATH_PYTHON
+
+-#AZ_PYTHON_WITH
+-
+-#if test -z "$PYTHON"; then
+-# AZ_PYTHON_PATH
+-#fi
+-
+-#AZ_PYTHON_VERSION_ENSURE([2.7])
+-
+-#AZ_PYTHON_RUN
+-
+-AX_PYTHON
+-
+-AC_CONFIG_FILES([Makefile])
+-AC_CONFIG_FILES([doc/Makefile])
+-AC_CONFIG_FILES([Config.py])
++AC_CONFIG_FILES([
++ Makefile
++ doc/Makefile
++ Config.py
++])
+
+ AC_OUTPUT
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,15 +1,53 @@
+-ACLOCAL_AMFLAGS = -I m4
+-
+ SUBDIRS = doc
+
+ dist_bin_SCRIPTS = mmaker
+
+-nobase_dist_pkgdata_DATA = *.py MenuMaker/*.py Prophet/*.py Prophet/Desktop/*.py Prophet/Legacy/*.py Prophet/Debian/*.py Prophet/Debian/menu/*
++python_PYTHON = \
++ Config.py \
++ Keywords.py \
++ Paths.py
++
++pythonMenuMakerdir = $(pythondir)/MenuMaker
++pythonMenuMaker_PYTHON = \
++ MenuMaker/BlackBox.py \
++ MenuMaker/CLI.py \
++ MenuMaker/Deskmenu.py \
++ MenuMaker/FluxBox.py \
++ MenuMaker/IceWM.py \
++ MenuMaker/__init__.py \
++ MenuMaker/OpenBox3.py \
++ MenuMaker/PekWM.py \
++ MenuMaker/WindowMaker.py \
++ MenuMaker/xBox.py \
++ MenuMaker/Xfce4.py
++
++pythonProphetdir = $(pythondir)/Prophet
++pythonProphet_PYTHON = \
++ Prophet/Categories.py \
++ Prophet/__init__.py
++
++pythonProphetDesktopdir = $(pythondir)/Prophet/Desktop
++pythonProphetDesktop_PYTHON = \
++ Prophet/Desktop/__init__.py
++
++pythonProphetLegacydir = $(pythondir)/Prophet/Legacy
++pythonProphetLegacy_PYTHON = \
++ Prophet/Legacy/Development.py \
++ Prophet/Legacy/Editor.py \
++ Prophet/Legacy/Emulator.py \
++ Prophet/Legacy/Graphics.py \
++ Prophet/Legacy/__init__.py \
++ Prophet/Legacy/Multimedia.py \
++ Prophet/Legacy/Network.py \
++ Prophet/Legacy/Shell.py
+
+-install-exec-local :
+- echo "#!/usr/bin/env $(PYTHON_BIN)" > $(DESTDIR)/$(bindir)/mmaker
+- echo "import sys; sys.path = ['$(pkgdatadir)'] + sys.path" >> $(DESTDIR)/$(bindir)/mmaker
+- echo "import MenuMaker.CLI" >> $(DESTDIR)/$(bindir)/mmaker
++pythonProphetDebiandir = $(pythondir)/Prophet/Debian
++pythonProphetDebian_PYTHON = \
++ Prophet/Debian/__init__.py
+
+-install-data-local :
+- $(PYTHON) -c 'import compileall; compileall.compile_dir(dir="$(DESTDIR)/$(pkgdatadir)", ddir="$(pkgdatadir)")'
++pythonProphetDebianMenudir = $(pythondir)/Prophet/Debian/menu
++dist_pythonProphetDebianMenu_DATA = \
++ Prophet/Debian/menu/debian-2.2r5 \
++ Prophet/Debian/menu/debian-8.1 \
++ Prophet/Debian/menu/ubuntu-5.04 \
++ Prophet/Debian/menu/ubuntu-5.10
diff --git a/x11-misc/menumaker/menumaker-0.99.10.ebuild b/x11-misc/menumaker/menumaker-0.99.10.ebuild
new file mode 100644
index 000000000000..7cb6eaad2a5d
--- /dev/null
+++ b/x11-misc/menumaker/menumaker-0.99.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit autotools python-r1
+
+DESCRIPTION="Utility that scans through the system and generates a menu of installed programs"
+HOMEPAGE="http://menumaker.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE="doc"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( sys-apps/texinfo )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.99.10-AM_PATH_PYTHON.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ configure() {
+ ECONF_SOURCE="${S}" econf PYTHON="${EPYTHON}"
+ }
+ python_foreach_impl run_in_build_dir configure
+}
+
+src_compile() {
+ compile() {
+ default
+ use doc && emake html
+ }
+ python_foreach_impl run_in_build_dir compile
+}
+
+src_install() {
+ compile() {
+ default
+ use doc && emake DESTDIR="${D}" install-html
+ }
+ python_foreach_impl run_in_build_dir compile
+ python_replicate_script "${ED%/}"/usr/bin/mmaker
+ einstalldocs
+}