summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-05 02:11:47 +0100
committerSam James <sam@gentoo.org>2022-09-05 02:11:47 +0100
commitc55f9c5f8d22c12c3fea7060820e63743930ac66 (patch)
tree5433c3077dad3986e5633ebc19e0782695892e79
parentsys-apps/cracklib-words: add 2.9.8 (diff)
downloadgentoo-c55f9c5f8d22c12c3fea7060820e63743930ac66.tar.gz
gentoo-c55f9c5f8d22c12c3fea7060820e63743930ac66.tar.bz2
gentoo-c55f9c5f8d22c12c3fea7060820e63743930ac66.zip
sys-apps/pcsc-tools: add 1.6.0
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 6fadd922a9c8..6af41199d366 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1 +1,2 @@
DIST pcsc-tools-1.5.7.tar.bz2 292637 BLAKE2B f0bfa9f680a2f2b348d2baef4b4b4567008163f47d7d7e6cec694cdc424626c5c6f18c475f0e8d4c5cd49111315b3c8a934fecf30afe90bbebc0a15f8d6f4a1d SHA512 58d70f41c5815297def7d8b64807e960db85719996771ecb43a4320d3f3fc82e2deb133d9ca97b3a4e8e76267294b3339d8883ba4770bdd0071566e1ce457501
+DIST pcsc-tools-1.6.0.tar.bz2 304960 BLAKE2B a60d280d39689d7eaa407aa5857c63af0acda3791e5d9f5c2f62048260178dc728fb179aed3c369340e192ba9b3d5db04bacbe5cc6ef1519c7cde55e10ca6b45 SHA512 951014510dcfd011fc08c92a927ed8a39751c15cd9278e9bd61693a2743a82d4b88907e01e013738f6b5afb569cb4d9e9802ee575c731b83da33e92f96eb5d50
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild
new file mode 100644
index 000000000000..76cab41d9392
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.6.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}