summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-13 18:27:41 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-13 22:57:02 +0200
commitc935c7ff7f010b01ba2af0500dec605965bb24b7 (patch)
treef8ab76e1409b2821bb6ef86757ab2afba8d68176
parentapp-emacs/persist: bump to 0.6.1 (diff)
downloadgentoo-c935c7ff7f010b01ba2af0500dec605965bb24b7.tar.gz
gentoo-c935c7ff7f010b01ba2af0500dec605965bb24b7.tar.bz2
gentoo-c935c7ff7f010b01ba2af0500dec605965bb24b7.zip
app-emacs/xclip: bump to 1.11.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/xclip/Manifest1
-rw-r--r--app-emacs/xclip/xclip-1.11.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/xclip/Manifest b/app-emacs/xclip/Manifest
index b8f8a5dbcd43..421759966e53 100644
--- a/app-emacs/xclip/Manifest
+++ b/app-emacs/xclip/Manifest
@@ -1 +1,2 @@
+DIST xclip-1.11.1.tar.gz 4986 BLAKE2B 553f6b11ec9129426b8ace2c09e285949f9463d8b17152b08c8e63782fe2cbe6127f74982ffe3bb3b27b74d4e49b74660bb326106bcc559e246a6697d7944052 SHA512 2d81f40db94a2e5acb2c5f63d3b51f3de8974c5598a2794df3fc60a55f78238636b157d00bf95a768c0636d718b6eb1abd6d9d2a72d8e3d2f1238b5b4b5e1d55
DIST xclip-1.11.el.xz 4500 BLAKE2B 19983f20979bfa96b15d88c9404664c9467cb7254c3eadcf57237ed733db516a5892f9b80d6289c6c4634ec34e16c4f09d0d17bdd35d1912455d79b4b4764f53 SHA512 8370f7bc695198004608e2348ded21a602ff6f062e2d3369a8ebc0c8d17e3d75da975160830b31e5ecaca67247c51f3950a8dfaf0357db5ff5f0e2296358547d
diff --git a/app-emacs/xclip/xclip-1.11.1.ebuild b/app-emacs/xclip/xclip-1.11.1.ebuild
new file mode 100644
index 000000000000..5a164bad3869
--- /dev/null
+++ b/app-emacs/xclip/xclip-1.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+[[ "${PV}" == "1.11.1" ]] && COMMIT="7febe164de2a881b83b9d604d3c7cf20b69f422d"
+
+inherit elisp readme.gentoo-r1 optfeature
+
+DESCRIPTION="Emacs Interface to XClip"
+HOMEPAGE="https://elpa.gnu.org/packages/xclip.html"
+SRC_URI="https://git.savannah.gnu.org/gitweb/?p=emacs/elpa.git;a=snapshot;h=${COMMIT};sf=tgz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/elpa-${COMMIT:0:7}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOC_CONTENTS="To enable xclip-mode, add (xclip-mode 1) to your ~/.emacs file."
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+
+ optfeature "X11 clipboard support" x11-misc/xclip x11-misc/xsel
+ optfeature "Wayland clipboard support" gui-apps/wl-clipboard
+}