summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-21 16:09:48 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-23 01:21:27 -0400
commitd5a6ca6fd8a8b6372a4adc6eff00ce990f543cc4 (patch)
tree7a2487f306d8a8af11141b8d60a01e3bc94fba3c
parentgnome-extra/nemo: avoid automagic dependency on gtk+[X]; don't restrict wayland (diff)
downloadgentoo-d5a6ca6fd8a8b6372a4adc6eff00ce990f543cc4.tar.gz
gentoo-d5a6ca6fd8a8b6372a4adc6eff00ce990f543cc4.tar.bz2
gentoo-d5a6ca6fd8a8b6372a4adc6eff00ce990f543cc4.zip
gnome-extra/cinnamon-control-center: avoid automagic deps on gtk+[X,wayland]
Currently, one is forced to compile c-c-c and gtk with the same value of USE=wayland which makes it difficult to provide generically reusable binaries. It is better than automagically depending on wayland and then lacking it, but not ideal. Preferable would be for c-c-c[wayland] to require gtk+[wayland] but when built without wayland support, to not care whether gtk itself is. We now support a mechanism for packages to opt out of gtk providing the API, for use by packages that don't provide a `-D wayland=true` but autodetect whether gtk was built with it. Use that mechanism. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
-rw-r--r--gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0-r1.ebuild (renamed from gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0.ebuild)7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0.ebuild b/gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0-r1.ebuild
index 7ee5c7dde989..5688c0e82a1d 100644
--- a/gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0.ebuild
+++ b/gnome-extra/cinnamon-control-center/cinnamon-control-center-6.2.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit meson gnome2-utils python-any-r1 xdg virtualx
+inherit meson flag-o-matic gnome2-utils python-any-r1 xdg virtualx
DESCRIPTION="Cinnamons's main interface to configure various aspects of the desktop"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cinnamon-control-center"
@@ -28,7 +28,7 @@ COMMON_DEPEND="
>=sys-auth/polkit-0.103
>=sys-power/upower-0.99.8:=
>=x11-libs/gdk-pixbuf-2.23.0:2
- >=x11-libs/gtk+-3.16.0:3[wayland=]
+ >=x11-libs/gtk+-3.24.41-r1:3[wayland?,X]
>=dev-libs/libgudev-232
>=x11-libs/libnotify-0.7.3
x11-libs/cairo
@@ -88,6 +88,9 @@ src_prepare() {
}
src_configure() {
+ # defang automagic dependencies
+ use wayland || append-cflags -DGENTOO_GTK_HIDE_WAYLAND
+
local emesonargs=(
$(meson_use colord color)
$(meson_use modemmanager)