summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-11 04:51:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-11 05:05:53 +0200
commitd97e00fc9ab06be1ad59e0e1778d02efed395382 (patch)
tree0156b0b627716e1c542ad3fb5b99cd9f94802b55
parentdev-python/aiohttp: Bump to 3.10.10 (diff)
downloadgentoo-d97e00fc9ab06be1ad59e0e1778d02efed395382.tar.gz
gentoo-d97e00fc9ab06be1ad59e0e1778d02efed395382.tar.bz2
gentoo-d97e00fc9ab06be1ad59e0e1778d02efed395382.zip
dev-python/ftfy: Bump to 6.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ftfy/Manifest1
-rw-r--r--dev-python/ftfy/ftfy-6.3.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ftfy/Manifest b/dev-python/ftfy/Manifest
index e229a1a69313..cf5ab4284fed 100644
--- a/dev-python/ftfy/Manifest
+++ b/dev-python/ftfy/Manifest
@@ -1,2 +1,3 @@
DIST ftfy-6.2.0.tar.gz 63675 BLAKE2B 4d2455c004737b2914edcdf22dc53e433f1f9d9a1b469f8b34069ce7a4b04c30a5b2a0d76db35d8e1f9ba0469cdff604271e7331f9fca0d8b579cc61c422cde1 SHA512 31724b3f65936a146f567a493988b3a3ce5ba87ac7578b97a64f0946cc20d09fcab040964cec9bcf3fbac1f79cad0b67c5e74aaa871a7d6c856f5939e7a30529
DIST ftfy-6.2.3.tar.gz 64165 BLAKE2B 83fdd2ba0b8b321b2cbac62c4e41a68356cc8a73970c0683aca8915624b622d1ef462c4724afd1dbcae494387aad3b97ba836cc47d433fb10b57a5c1019ee602 SHA512 6711dbe9750db6bc25c57d5d600d1db52eff6f22caa7ff89c06615bbd7dd612cca56f9e9a35c633648747c421f2e710a6e24ee1f9a6d6df0ac6f6049a5189e8e
+DIST ftfy-6.3.0.tar.gz 362118 BLAKE2B 30dd2a94a155203827bd43f05371f5a8ac3fb880a621f1d6323cfd0570310f326ef3d97dac3f82bc683dfd9a7b2eb3c7d056b3dbd9ef94a950046cb2a2c567b1 SHA512 1fd1c209961a69a4424f3b0f51f599d7b1a86035470cb3a0ceef998f0b7a7dc80d709b2d2efa122beac16819a46799255dbb6bce58949c28c3d919c20431c865
diff --git a/dev-python/ftfy/ftfy-6.3.0.ebuild b/dev-python/ftfy/ftfy-6.3.0.ebuild
new file mode 100644
index 000000000000..5cfb846a8c63
--- /dev/null
+++ b/dev-python/ftfy/ftfy-6.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fixes mojibake and other problems with Unicode, after the fact"
+HOMEPAGE="
+ https://ftfy.readthedocs.io/en/latest/
+ https://github.com/rspeer/python-ftfy/
+ https://pypi.org/project/ftfy/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest