summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-07 14:11:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-07 14:11:34 +0200
commitf410614ae7156ac757668820332c35a42c789a80 (patch)
tree5240abe212ee0328e2e3ef869659d4386d34396e
parentdev-python/hcloud: Remove old (diff)
downloadgentoo-f410614ae7156ac757668820332c35a42c789a80.tar.gz
gentoo-f410614ae7156ac757668820332c35a42c789a80.tar.bz2
gentoo-f410614ae7156ac757668820332c35a42c789a80.zip
dev-python/python-glanceclient: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-glanceclient/Manifest1
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.6.0.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/python-glanceclient/Manifest b/dev-python/python-glanceclient/Manifest
index 96dd359f68fd..e73f5c9d63b6 100644
--- a/dev-python/python-glanceclient/Manifest
+++ b/dev-python/python-glanceclient/Manifest
@@ -1,2 +1 @@
-DIST python-glanceclient-4.6.0.tar.gz 206480 BLAKE2B 302414b0fcf85ec9a8e53e9bf43c5801df82826524780249e9c4b46b44ca2e53c1c5d63f6e80c73dee2a59009a3e0aa1df591ecb2a4d000b74ee078b4810de2c SHA512 ed9d554d40a03134bc8871fbf712dd4bb2aab5e18854fd9c07df0d20dead1a9f3473bc4253ba4dd8c87cf7227148c637718461d45cd01bd9aaf673f7fc7ee9fc
DIST python-glanceclient-4.7.0.tar.gz 208314 BLAKE2B 97a157781efc0fc67d67f25119edea2a3f85344447e4614f41c73a3f9abda1c9ba646ca7f8d7b2b315b4572997ec730e6eef1782852590e7021f69c61b02920b SHA512 5fff50d499b7fe439cb43c7d396a7dd28439f45cfc157e4fdefb029e7db4cc9955911aae9c4d748fc19bd10ad66d299e26a1178a63a866fef7fb60164467c79d
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.6.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.6.0.ebuild
deleted file mode 100644
index b1ca97d43703..000000000000
--- a/dev-python/python-glanceclient/python-glanceclient-4.6.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A client for the OpenStack Glance API"
-HOMEPAGE="
- https://opendev.org/openstack/python-glanceclient/
- https://github.com/openstack/python-glanceclient/
- https://pypi.org/project/python-glanceclient/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
- test? (
- dev-python/ddt[${PYTHON_USEDEP}]
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/tempest[${PYTHON_USEDEP}]
- dev-python/testscenarios[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-
-PATCHES=(
- # combined patch for urllib3-2 and py3.12 test failures
- # https://bugs.launchpad.net/python-glanceclient/+bug/2069684
- # https://bugs.launchpad.net/python-glanceclient/+bug/2069682
- "${FILESDIR}/${P}-test.patch"
-
- # py3.13 added close() to mock_open calls
- # https://review.opendev.org/c/openstack/python-glanceclient/+/923628
- "${FILESDIR}/${P}-test-py3.13.patch"
-)
-
-python_test() {
- # functional tests require cloud instance access
- eunittest -b glanceclient/tests/unit
-}