summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-13 21:44:43 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-03-13 21:45:51 +0100
commit1303e166ecdcba92654477b03909ab132aa77510 (patch)
tree33cefca772968edd3dfa2f401014f841fee62fcf /acct-user
parentdev-perl/Search-Sitemap: new package, for use with Bugzilla (diff)
downloadgentoo-1303e166ecdcba92654477b03909ab132aa77510.tar.gz
gentoo-1303e166ecdcba92654477b03909ab132aa77510.tar.bz2
gentoo-1303e166ecdcba92654477b03909ab132aa77510.zip
acct-user/git: add git use flag
Adding 'git' use flag, to be able to install git user for using with plain git without any additional software, when hosting git repos. Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'acct-user')
-rw-r--r--acct-user/git/git-0-r2.ebuild (renamed from acct-user/git/git-0-r1.ebuild)12
1 files changed, 7 insertions, 5 deletions
diff --git a/acct-user/git/git-0-r1.ebuild b/acct-user/git/git-0-r2.ebuild
index 0e86336ce40b..18e2d5f67173 100644
--- a/acct-user/git/git-0-r1.ebuild
+++ b/acct-user/git/git-0-r2.ebuild
@@ -1,14 +1,14 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit acct-user
DESCRIPTION="Git repository hosting user"
-IUSE="gitea gitolite"
-REQUIRED_USE="^^ ( gitea gitolite )"
+IUSE="git gitea gitolite"
+REQUIRED_USE="^^ ( git gitea gitolite )"
ACCT_USER_ID=196
ACCT_USER_HOME_OWNER=git:git
@@ -19,7 +19,9 @@ ACCT_USER_GROUPS=( git )
acct-user_add_deps
pkg_setup() {
- if use gitea; then
+ if use git; then
+ ACCT_USER_HOME=/var/lib/git
+ elif use gitea; then
ACCT_USER_HOME=/var/lib/gitea
elif use gitolite; then
ACCT_USER_HOME=/var/lib/gitolite