summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-02-01 13:09:11 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-02-01 13:09:28 -0600
commit041a67a4eca70d11f152ba730a49be738ae2ed83 (patch)
tree0aa19f65e738957894a849146cc31761b1f8f1ed /app-admin/ansible
parentapp-admin/ansible-base: 2.12.2 bump (diff)
downloadgentoo-041a67a4eca70d11f152ba730a49be738ae2ed83.tar.gz
gentoo-041a67a4eca70d11f152ba730a49be738ae2ed83.tar.bz2
gentoo-041a67a4eca70d11f152ba730a49be738ae2ed83.zip
app-admin/ansible: 5.3.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-5.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index d34d730350aa..a966748ece1d 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1,3 @@
DIST ansible-4.6.0.tar.gz 35644507 BLAKE2B 94f544caa81ba7d20493f469483612f2ebf9eb1c4be18006b5ca6afdb3bd45428226340a0658b8f1ebecf8bd06396763ba888bb1cbd48aa6b71aaa6a56542d38 SHA512 5b7fad69628dded0b42a25e3f2fbbcc30ef876dc3f97dc1dff2c7db6443d1506fe5db62bc4d8a00ebfb7dc78ecc205a56bea3bf760f85260c835b2286f63b702
DIST ansible-5.0.1.tar.gz 38449873 BLAKE2B 1b2cfab6f851c3eb9cc124c7178d9a156a4279fa539e960213289a6e7c8e6b4efcde009fe8484259150ffb8a2ce90080c7e9356308bea6f46e51645518593f6b SHA512 ade29442ed12f635161b2a98dabce75c125b8eac855b33cfc484f35624e55f51534a8a0c414450db60cdf3d8f25ae6ab66946a1cd2c3468f921d7a2ced38a2de
+DIST ansible-5.3.0.tar.gz 38005050 BLAKE2B 57e196fe005060cf53f9d76e33e61d461035fc9472254e90c28eb5107dc3546aa38c5f3bc340a7ace518e853bc50bb4299015dc087e286064efc661825df5ba9 SHA512 15f814f23305ceae3426464bccd6fc5cfb9b7b86b6634ce9b867d20c3d512e669387cbd12cb2ea03a66c352272aa72b53f255dfdd03c3198b70fc286e527f43a
diff --git a/app-admin/ansible/ansible-5.3.0.ebuild b/app-admin/ansible/ansible-5.3.0.ebuild
new file mode 100644
index 000000000000..999bc1a1edb8
--- /dev/null
+++ b/app-admin/ansible/ansible-5.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-base-2.12.0
+ <app-admin/ansible-base-2.13"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}