summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2023-02-25 12:13:40 -0500
committerMichael Orlitzky <mjo@gentoo.org>2023-02-25 12:13:40 -0500
commita4575688588e9082f38a92deec50ebfc3207ca6e (patch)
treec6b2bb578a7b8e6353ff6fb34b88147f75f80fcc /app-admin/djbdns-logparse
parentapp-backup/untangle-https-backup: update EAPI 7 -> 8, python-3.11. (diff)
downloadgentoo-a4575688588e9082f38a92deec50ebfc3207ca6e.tar.gz
gentoo-a4575688588e9082f38a92deec50ebfc3207ca6e.tar.bz2
gentoo-a4575688588e9082f38a92deec50ebfc3207ca6e.zip
app-admin/djbdns-logparse: support python-3.11.
Closes: https://bugs.gentoo.org/896464 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-admin/djbdns-logparse')
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..155ae489821a
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="http://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}