summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-05-15 12:53:30 +0200
committerAgostino Sarubbo <ago@gentoo.org>2023-05-15 12:53:30 +0200
commit991ddceeb6910106089b091a2cada8f788fe0e56 (patch)
treefeb136f95fc4e03df89952b64f6bfa410adf6659 /app-admin/exo
parentdistutils-r1.eclass: Fix sed mistake (diff)
downloadgentoo-991ddceeb6910106089b091a2cada8f788fe0e56.tar.gz
gentoo-991ddceeb6910106089b091a2cada8f788fe0e56.tar.bz2
gentoo-991ddceeb6910106089b091a2cada8f788fe0e56.zip
app-admin/exo: version bump to 1.69.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.69.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 0962e232152d..ff7f8fe09bec 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.68.0.gh.tar.gz 5673687 BLAKE2B 7e1b8a03d902e21052dbbdc0e1fb7bc0316061d021fb0dae901fcefcd3cf5560113c3ac068353de9039c8b672fb75e483a3be886702920431cf1cb040c4ad38e SHA512 01663f651348cbb43d5c382b57904792bfa1b954dbe7c8661084c95133828372c643c52db8b66f36a8b791330c80f922a324b359b6b920fcccec41e85e1b1e1b
+DIST exo-1.69.0.gh.tar.gz 5679426 BLAKE2B 583a1bb405ec707b371c67f59240e7fc192b07c94698c86a0acb652bd946c817d581597b9dffe0d2276585e462cc67de840005e337c228d0fe779ce002c5e3b5 SHA512 79f8a54ff9baa09e2bfd3dd2cedfa605eec958838036c368394fd684f12eb805373fe44c5931a3c419bd829447736d94fdba3e14f71f3a4bbe9fc0e4e7c7cdad
diff --git a/app-admin/exo/exo-1.69.0.ebuild b/app-admin/exo/exo-1.69.0.ebuild
new file mode 100644
index 000000000000..8b7ec86e5d08
--- /dev/null
+++ b/app-admin/exo/exo-1.69.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit=" || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}