summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-31 10:48:27 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-31 10:50:00 -0600
commitfa48c0954dfa132b608cf70046f47b1d159dc2ef (patch)
tree96d120a346b099f6f262cf5dc2293df197daeb1e /app-admin/opentofu
parentdev-ruby/git: add missing test dependency (diff)
downloadgentoo-fa48c0954dfa132b608cf70046f47b1d159dc2ef.tar.gz
gentoo-fa48c0954dfa132b608cf70046f47b1d159dc2ef.tar.bz2
gentoo-fa48c0954dfa132b608cf70046f47b1d159dc2ef.zip
app-admin/opentofu: add 1.6.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/opentofu')
-rw-r--r--app-admin/opentofu/Manifest2
-rw-r--r--app-admin/opentofu/opentofu-1.6.1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/opentofu/Manifest b/app-admin/opentofu/Manifest
index 0ceee9976ba8..214190538ece 100644
--- a/app-admin/opentofu/Manifest
+++ b/app-admin/opentofu/Manifest
@@ -1,2 +1,4 @@
DIST opentofu-1.6.0-deps.tar.xz 332007504 BLAKE2B 1c2a7d2350944d34308baa0566977aad914b3c4f989ba90d51cb52e3001d11e56952906b0dab7adc5cef261290b748c0567e35c66f6701d62d750e18d0acea5f SHA512 5c5644b2caef5439e50865569abec133ba57a6e6581d8f8d38500671818079b471afcd86422858475b1ca912bdb75fe0b91227012f5c597bcaabe1a215b2eb09
DIST opentofu-1.6.0.tar.gz 3696642 BLAKE2B e224ce14f04d07638d03b9a11ab251cd820acc86774f9c82f38f5bcfc38b62bbdbc70377e722a4dd2bd65f917ba0fc200ccaaeafdbd9430af66586491c7627eb SHA512 758f4ff79e526e9494e1e98dd927dbeb803b45df1f8bc15c3a9bca8343d7285b9130bfe5f19f6ddd7fd403b72d852b0d51542c058174e4bd5eed3c729b394bdb
+DIST opentofu-1.6.1-deps.tar.xz 332000152 BLAKE2B bfa5bee3c7ba8cc79cd8f81137fb611abce0b806813475deab0e5546542910cc391252ebb3054badf3a8bfe17f25d30ce570065591aaa6148ad6bd7c42aa8e2e SHA512 10e5519b1be53a5ec1191dec8f73960da72ca53cc5284ef9a72139ce0e1db2a9213fbed696088644414ef0fb589c26a7980f695b79192f0e5f039f3dfcfc91e8
+DIST opentofu-1.6.1.tar.gz 3709010 BLAKE2B 3d172a4228ff10608dc74da6980eda38ec9afa13ac4bbfeb4ae3fb3142af81fc30988a99fea01ee7988b7ad057efbe1b270b4b880e4152ec3d87939f29ae8614 SHA512 6d98e5f03340853ad3f516ad890fe297c4239c03c0c5d4b0e7efc490b734ce2948bbd3ee5d1375d9eade2ea4a6ef71dbb22a5dd48fc81df5a9440ce73090a92e
diff --git a/app-admin/opentofu/opentofu-1.6.1.ebuild b/app-admin/opentofu/opentofu-1.6.1.ebuild
new file mode 100644
index 000000000000..544c2e0b5f16
--- /dev/null
+++ b/app-admin/opentofu/opentofu-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="The open source infrastructure as code tool"
+HOMEPAGE="https://www.opentofu.org/"
+SRC_URI="https://github.com/opentofu/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/gox"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ export CGO_ENABLED=0
+ gox \
+ -os=$(go env GOOS) \
+ -arch=$(go env GOARCH) \
+ -output bin/tofu \
+ -verbose \
+ ./cmd/tofu || die
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " tofu -install-autocomplete"
+}