summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-20 03:17:57 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-20 03:18:54 -0500
commit3d0d39b70b8a5f544224f9b8fbae680808ad8122 (patch)
tree8bf787920d75605fda7551fd7984f84f1974466a /app-admin/puppet
parentmail-client/nail: Remove last-rited pkg (diff)
downloadgentoo-3d0d39b70b8a5f544224f9b8fbae680808ad8122.tar.gz
gentoo-3d0d39b70b8a5f544224f9b8fbae680808ad8122.tar.bz2
gentoo-3d0d39b70b8a5f544224f9b8fbae680808ad8122.zip
app-admin/puppet: fix patch for puppet 6.4.1
Fixes: https://bugs.gentoo.org/683836 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/files/puppet-fix-tests-6.4.1.patch18
-rw-r--r--app-admin/puppet/puppet-6.4.1.ebuild2
2 files changed, 19 insertions, 1 deletions
diff --git a/app-admin/puppet/files/puppet-fix-tests-6.4.1.patch b/app-admin/puppet/files/puppet-fix-tests-6.4.1.patch
new file mode 100644
index 000000000000..6b7b5b484792
--- /dev/null
+++ b/app-admin/puppet/files/puppet-fix-tests-6.4.1.patch
@@ -0,0 +1,18 @@
+--- spec/unit/network/http/api/indirected_routes_spec.rb 2018-09-17 19:36:56.000000000 -0500
++++ spec/unit/network/http/api/indirected_routes_spec.rb 2018-09-19 10:52:35.841614932 -0500
+@@ -144,15 +144,6 @@
+ handler.uri2indirection("GET", uri_escaped, params)
+ end
+
+- it "when the environment is unknown should remove :environment from params passed to check_authorization and therefore fail" do
+- expect(handler).to receive(:check_authorization).with(anything,
+- anything,
+- excluding(:environment))
+- expect(lambda { handler.uri2indirection("GET",
+- "#{master_url_prefix}/node/bar",
+- {:environment => 'bogus'}) }).to raise_error(not_found_error)
+- end
+-
+ it "should not URI unescape the indirection key as passed through to a call to check_authorization" do
+ expect(handler).to receive(:check_authorization).with(anything, anything, hash_including(environment: be_a(Puppet::Node::Environment).and(have_attributes(name: :env))))
+
diff --git a/app-admin/puppet/puppet-6.4.1.ebuild b/app-admin/puppet/puppet-6.4.1.ebuild
index 1d12aee25d2c..0fa5d7101201 100644
--- a/app-admin/puppet/puppet-6.4.1.ebuild
+++ b/app-admin/puppet/puppet-6.4.1.ebuild
@@ -67,7 +67,7 @@ all_ruby_prepare() {
rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
# can't be run within portage.
- epatch "${FILESDIR}/puppet-fix-tests-6.0.0.patch"
+ epatch "${FILESDIR}/puppet-fix-tests-6.4.1.patch"
# fix systemd path
epatch "${FILESDIR}/puppet-systemd.patch"