summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-01-26 23:20:54 +0000
committerJason Zaman <perfinion@gentoo.org>2021-02-15 12:21:05 -0800
commit25af7bcd746298e45168d2bf3695230fa02683ca (patch)
tree28958e4dda7b82855ef495c061a4f8ff814e3c17 /app-admin/selint/selint-1.2.0.ebuild
parentmedia-sound/sc2mpd: remove unused patches (diff)
downloadgentoo-25af7bcd746298e45168d2bf3695230fa02683ca.tar.gz
gentoo-25af7bcd746298e45168d2bf3695230fa02683ca.tar.bz2
gentoo-25af7bcd746298e45168d2bf3695230fa02683ca.zip
app-admin/selint: Version updated to 1.2.0.
Closes: https://github.com/gentoo/gentoo/pull/19231 Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'app-admin/selint/selint-1.2.0.ebuild')
-rw-r--r--app-admin/selint/selint-1.2.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/selint/selint-1.2.0.ebuild b/app-admin/selint/selint-1.2.0.ebuild
new file mode 100644
index 000000000000..a0e18d3a3fef
--- /dev/null
+++ b/app-admin/selint/selint-1.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Static code analysis of refpolicy style SELinux policy"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse:=
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}