summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-01-24 20:23:50 +0100
committerDavid Seifert <soap@gentoo.org>2021-01-24 20:23:50 +0100
commit83d9afd518cff628d49a5f10daacb6b7fdebd0ca (patch)
tree42c71b297d9c08840811c542b3e3e8b530cc6ada /app-admin
parentnet-analyzer/icinga2: cleanup old (diff)
downloadgentoo-83d9afd518cff628d49a5f10daacb6b7fdebd0ca.tar.gz
gentoo-83d9afd518cff628d49a5f10daacb6b7fdebd0ca.tar.bz2
gentoo-83d9afd518cff628d49a5f10daacb6b7fdebd0ca.zip
app-admin/newsyslog: Fix build with gcc-10
Closes: https://bugs.gentoo.org/707452 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/newsyslog/files/newsyslog-1.1.0.81-fno-common.patch43
-rw-r--r--app-admin/newsyslog/files/newsyslog-1.1.0.81-html.patch4
-rw-r--r--app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild30
3 files changed, 61 insertions, 16 deletions
diff --git a/app-admin/newsyslog/files/newsyslog-1.1.0.81-fno-common.patch b/app-admin/newsyslog/files/newsyslog-1.1.0.81-fno-common.patch
new file mode 100644
index 000000000000..b63e439064ee
--- /dev/null
+++ b/app-admin/newsyslog/files/newsyslog-1.1.0.81-fno-common.patch
@@ -0,0 +1,43 @@
+https://bugs.gentoo.org/707452
+--- a/sig2str.c
++++ b/sig2str.c
+@@ -63,7 +63,7 @@ extern const unsigned int sys_nsigname; /* also from sys_signame.c */
+ #endif
+
+ #if !defined(SYS_SIGNAME_DECLARED)
+-const char *const sys_signame[]; /* defined in sys_signame.c */
++extern const char *const sys_signame[]; /* defined in sys_signame.c */
+ #endif
+
+ #if !defined(HAVE_DECL_SIG2STR)
+--- a/str2sig.c
++++ b/str2sig.c
+@@ -29,7 +29,7 @@ static const char rcsid[] =
+ #include "newsyslog.h" /* generic portability definitions */
+
+ #if !defined(SYS_SIGNAME_DECLARED)
+-const char *const sys_signame[]; /* defined in signame.c */
++extern const char *const sys_signame[]; /* defined in signame.c */
+ #endif
+
+ /* NetBSD gained sys_nsig sometime just prior to 1.4 */
+@@ -65,7 +65,7 @@ extern const unsigned int sys_nsigname; /* also from sys_signame.c */
+ #endif
+
+ #if !defined(SYS_SIGNAME_DECLARED)
+-const char *const sys_signame[]; /* defined in sys_signame.c */
++extern const char *const sys_signame[]; /* defined in sys_signame.c */
+ #endif
+
+ #if !defined(HAVE_DECL_STR2SIG)
+--- a/sys_signame.c
++++ b/sys_signame.c
+@@ -22,7 +22,7 @@
+ #include "config.h"
+ #include <sys/types.h>
+
+-const char *const sys_signame[] = {
++extern const char *const sys_signame[] = {
+ /* 0 */ "Signal 0", /* Fake value for zero */
+ /* 1 */ "HUP", /* Control TTY hangup */
+ /* 2 */ "INT", /* Control TTY interrupt */
diff --git a/app-admin/newsyslog/files/newsyslog-1.1.0.81-html.patch b/app-admin/newsyslog/files/newsyslog-1.1.0.81-html.patch
index 873cfc10991a..1e2b07019f35 100644
--- a/app-admin/newsyslog/files/newsyslog-1.1.0.81-html.patch
+++ b/app-admin/newsyslog/files/newsyslog-1.1.0.81-html.patch
@@ -1,5 +1,5 @@
---- a/Makefile.in 2018-06-24 14:36:18.647850208 +0000
-+++ b/Makefile.in 2018-06-24 14:37:50.216321235 +0000
+--- a/Makefile.in
++++ b/Makefile.in
@@ -763,7 +763,7 @@
.8.8.html:
diff --git a/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild b/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild
index 9b51143e7783..3fb7cf3ec3a6 100644
--- a/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild
+++ b/app-admin/newsyslog/newsyslog-1.1.0.81-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,28 +11,28 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
-DEPEND="
- sys-apps/groff"
-
+BDEPEND="sys-apps/groff"
RDEPEND="
virtual/cron
app-arch/gzip"
-PATCHES=( "${FILESDIR}/${P}-html.patch" )
-
-DOCS=( newsyslog.conf AUTHORS ChangeLog INSTALL NEWS ToDo )
+PATCHES=(
+ "${FILESDIR}"/${P}-html.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+)
src_configure() {
- local myconf="--with-syslogd_pid=/var/run/syslog.pid"
-
+ local myconf=(
+ --with-gzip
+ --with-newsyslog_conf="${EPREFIX}"/etc/newsyslog.conf
+ )
if has_version 'app-admin/syslog-ng'; then
- myconf="--with-syslogd_pid=/var/run/syslog-ng.pid"
+ myconf+=( --with-syslogd_pid="${EPREFIX}"/var/run/syslog-ng.pid )
+ else
+ myconf+=( --with-syslogd_pid="${EPREFIX}"/var/run/syslog.pid )
fi
- econf \
- --with-gzip \
- --with-newsyslog_conf=/etc/newsyslog.conf \
- ${myconf}
+ econf "${myconf[@]}"
}
src_install() {
@@ -40,5 +40,7 @@ src_install() {
DESTDIR="${D}" \
catmandir="${T}"/dont-install \
install
+
einstalldocs
+ dodoc newsyslog.conf ToDo
}