summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2024-08-04 05:34:55 -0400
committerJoshua Kinard <kumba@gentoo.org>2024-08-04 05:36:57 -0400
commit5485da75f357ff0e9833a7c69c379e0a36b506f0 (patch)
tree10c47e8945e43634649cd71d2d216b18fe25b75d /app-arch/lrzip-next/files/lrzip-next-0.13.1-use-acx_pthread-configure_ac.patch
parentdev-util/kcov: add 43 and adoption (diff)
downloadgentoo-5485da75f357ff0e9833a7c69c379e0a36b506f0.tar.gz
gentoo-5485da75f357ff0e9833a7c69c379e0a36b506f0.tar.bz2
gentoo-5485da75f357ff0e9833a7c69c379e0a36b506f0.zip
app-arch/lrzip-next: Update to 0.13.1
Update to v0.13.1, which includes lzma SDK 24.x from 7-Zip upstream. Partially addresses some issues found on musl, however, it will remain masked on musl for the time being until a sigsegv bug in libzpaq is fixed. Bug: https://bugs.gentoo.org/925547 Bug: https://bugs.gentoo.org/925618 Signed-off-by: Joshua Kinard <kumba@gentoo.org>
Diffstat (limited to 'app-arch/lrzip-next/files/lrzip-next-0.13.1-use-acx_pthread-configure_ac.patch')
-rw-r--r--app-arch/lrzip-next/files/lrzip-next-0.13.1-use-acx_pthread-configure_ac.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-arch/lrzip-next/files/lrzip-next-0.13.1-use-acx_pthread-configure_ac.patch b/app-arch/lrzip-next/files/lrzip-next-0.13.1-use-acx_pthread-configure_ac.patch
new file mode 100644
index 000000000000..ae0af555ac91
--- /dev/null
+++ b/app-arch/lrzip-next/files/lrzip-next-0.13.1-use-acx_pthread-configure_ac.patch
@@ -0,0 +1,33 @@
+diff -Naurp lrzip-next-0.12.6.orig/configure.ac lrzip-next-0.12.6/configure.ac
+--- lrzip-next-0.12.6.orig/configure.ac 2024-01-27 08:42:15.000000000 -0500
++++ lrzip-next-0.12.6/configure.ac 2024-03-11 16:27:53.972571412 -0400
+@@ -168,16 +168,19 @@ AC_CHECK_LIB(gcrypt, gcry_md_open, ,
+ AC_CHECK_FUNCS(mmap strerror)
+ AC_CHECK_FUNCS(getopt_long)
+
+-AX_PTHREAD
+-LIBS="$PTHREAD_LIBS $LIBS"
+-AS_IF([test x"$debug" = xyes],
+- CFLAGS="-g -Og -DDEBUG"
+- CXXFLAGS="-g -Og -DDEBUG",
+- CFLAGS="$CFLAGS"
+- CXXFLAGS="$CXXFLAGS")
+-
+-CFLAGS+=" $PTHREAD_CFLAGS"
+-CXXFLAGS+=" $PTHREAD_CFLAGS"
++ACX_PTHREAD([
++ LIBS="$LIBS $PTHREAD_LIBS"
++ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
++ CXXFLAGS="$CXXFLAGS $PTHREAD_CFLAGS"
++ CC="$PTHREAD_CC"
++ CXX="$PTHREAD_CXX"
++ AC_SUBST([LIBS])
++ AC_SUBST([CFLAGS])
++ AC_SUBST([CXXFLAGS])
++ AC_SUBST([CC])
++ AC_SUBST([CXX])
++ ],
++ [AC_MSG_ERROR([POSIX threads support is required])])
+
+ ## test for ARM or other non x86 processor
+ ## must use -DNOJIT for compiling zpaq